[linux mint17] Failed to set temporary file permissions-Error 95


#1

This error appears after I have installed Kicad, started a schematic project and tried to set a relative path to libraries via Preferences==>Component libraries.
…/user/share/kicad/library
This is the latest version and installed on Mint 17, everything fully up to date. Can someone provide a simple solution? An absolute path does not work either. Thanks.


#2

Did you solve your problem?

Are you talking about Eeschema?

When exactly does the error message appear?

What happens when you answer “No” to “Do you want to use a relative path”? Is it the same error message?

What is the absolute path of the “…/user/share/kicad/library” directory? Did you create it?
If you created the directory, please you run this command then retry:
chmod -R 777 ../user/share/kicad/library


#3

No solution yet, but Eeschema seems to work normally anyway. I receive the error message when I press OK from Preferences==>Component Libraries. I can’t remember whether relative path was used, I think not. The chmod command returns an error saying file or directory does not exist.


#4

I am getting the same Error with Ubuntu 16.04.2. I downloaded a Library, unpacked it, and moved it to my network Drive, from where I access my Project. When I try to add this library, I get: “Failed to set temporary permissions (error 95:Operation not supported)”. When I login with ssh into my File-server and change permissions of this library with sudo chmod 777, the error message still appears.