Lines from dxf imported footprint

Hello everyone,

I’m into Kicad since 2 days and so far I love it!

I’m creating a new footprint and I’ve imported the outline using a dxf from autocad.

If I select one of these I dont see the little squares at the line extremes to adjust it, also right clicking on it I dont see Properties

It seems the lines are not imported as lines… Am I correct? Is there a way to solve this?

Thanks

You’ve been upgraded to ‘basic’ so that you can perhaps post a picture of what you are seeing. Also, what version of Kicad are you using and on what operating system?

1 Like

Thanks heremit!

Kicad is 5.1.10-10_14 running on OSx is Catalina 10.15.7

Schermata 2021-10-05 alle 16.40.27
Here I’ve selected one of the imported lines, but there are no handles to adjust it.


And this is what I see if, line selected, I right click (normally with lines I see “Properties…”)

I think it was an exporting issue.
I tried using dxf(2003) and it worked.

It stills import with some errors (arcs and lines here and there…) but they are easly corrected now that there are handles

1 Like