Line width in V5.1.0

I am running the latest release of KiCad (V5.1.0) with Win7 pro 64 bit.

I like to set the graphics lines to a small value like 0.01mm for the Dwgs.User and Edge.cuts layers.

This gives me fine control over the exact edge positions and also gets precise cross-hairs for component to edge spacing. I also do that for dimension lines.

I used to do this easily in V4.XX by selecting a short length of line and changing its width and the default value by right clicking the line and changing the parameters there. It would remain with the same width for any lines on the same layer through the whole editing time of the board.

Dimensions will now only change the text thickness, in V4 the line and text width changed together
In V5 the line stays at .15mm (default) whilst the text does change to .01mm thickness.

Drawings on Dwgs.user and edge.cuts can be set on individual lines from the line, select, properties tab which then stays at my selected width, but next time a line is drawn it has gone back to 0.15mm again. The set default in the right click edit line properties has gone. Only the selected line’s width can be changed.

The Edit Text & Graphics tab in EDIT tab seems to have no effect on the settings, it always defaults to 0.15 for any new line. (Using Modern Toolset).

Using legacy tools seems to start a block command and no line is drawn at all (mostly).

The lines can be set once drawn using the edit tab last mentioned but then all the lines on a selected layer are changed globally.

What I would like to do is draw lines on the Dwgs.User layer say at .02mm by default, then if I need a thicker size for something else, set that from the line properties (right click) tab. As this will only be for a small number of lines it is not a problem to do each one individually.

These settings do not appear to be covered at all in the manual, or any instructions about what the settings in the edit tab are intended to do.

Can anyone enlighten me how to set a default drawing width size that will persist through a session please?

There seems to be a bug in V5.1 related to line widths while importing DXF files. This may be related.

See the Text & Graphics section in the File > Board Setup… dialog. The sets the defaults for new items.

1 Like

@paulvdh Thanks for that. The problem I have is not dxf related.
@JeffYoung It is supposed to do that, as is the Edit/ Edit text & Graphics tab (presumably)
One of my PCB manufacturers asks for narrow profile layers so used to use .01mm in V4.0.x and they were OK with that.
I have to do some corner cuts on the board I am laying down now, and have set a drawing layer to 0.01mm. I set the PCB edge cuts to .05mm with the Edit tab and every time I select the edge cuts layer the width shown is 0mm.

This sets the edge cuts to an impossibly fine line, but as the diagonal line can be selected by mouse drag, its properties change to width = 0, and the next click gives me a message that the line width must be greater than 0, (which makes sense). I can set the selected line to .05mm but the rest of the layer remains at 0.
All very confusing.
It appears that if a line is drawn, it is fine and can be changed in its own properties tab, but then if the layer line width is changed or even set to the same value in the edit tab, then the line width is set to 0 on its properties tab. It appears to apply to the dwgs.user layer as well as PCB edges. I have not yet tried any other layers as am confused enough!
Has anyone else had this issue? I wonder if it is confined to windows only, or maybe windows 7 only?
I will try deleting the whole PCB outline and start with a finer setting rather than edit it mid-drawing.

The screen shots are very helpful. The problem is that you’re setting the line width to “<0.05>” instead of “0.05”. The angle brackets don’t parse and so the parser returns 0. (We should be checking for parse errors, but evidently we don’t here.)

1 Like


Me again. I found that out a few minutes ago after installing the latest nightly that I could get. Still the same, so I tried no brackets and it is fine. I very carefully was typing in the value and deleting the spare stops after the value.I sort of assumed that the brackets were essential to pass the value. Too long programming in weird versions of basic and Pascal!
Maybe the program can self delete the “< >” when a valid figure is entered?
Once the lines had set to ,0 new lines were (are?) drawn in width 0 by the way.

Thanks for sticking with me on this. Much appreciated.

It would be nice to collate these little snippets in a folder somewhere for idiots like me to refer to when the new version is so different from the last one, and the help files are half a version behind.

I was not sure at first about v4.0.x with its rather unpredictable footprints library management, but now V5.1.x is a great tool. Especially the way the environment can be set up at install as this was always a stumbling block for me as a windows user. It has some really sophisticated actions implemented as well. Love the new copper pour with click & adjust edges that really does work for example.
The caliper tool is great along with array for making multiple boards (panelising).

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.