Line over global labels is not visible

So, to signify active low, I can use ~{} to create a line over the text. I tend to use global labels quite a bit, and unfortunately with global labels, this doesn’t really work visually. The created line overlaps with the edges of the label, making it barely discernable,

Attached is an image showing a Fault signal, one with the overline, one without.

Any way to make this work, or is there currently no way with global labels?

Did you try changing the font text size?

With the default size of 1.27 i don’t have that issue.


1 Like

And it is always a good idea to post the used kicad version.

Im on version 7.0.2

I was using size 1.27 with the default KiCad font. Changing the font size doesn’t help, as the label resizes accordingly. But, turns out changing the type of font does fix this for me. Hadn’t occurred to me to change that for some reason before. I’ll be using the Calibri font from now on

Thank you both!

1 Like

another option to play with: File–>Schematic setup–>General–>Formatting–>global label margin.
Increasing this percentage-value increases the distance from global label textstring to surrounding shape.
I have good results with global label margin==30% (for standard Kicad font with 0.05"==1.27mm size)

1 Like

I remember a commit related to this. Try upgrading to 7.0.5

I have a side question. Untill this thread I never knew such a line was possible nor I thought about it. Is it considered common practice to use them like this? (I always just use a ‘normal’ Reset label :joy:)

It’s common practice if the reset is active on a low.

1 Like

Very common practice as it indicates active high or active low. I’ve seen some systems with a active high RESET so you need someway to distinguish between the two.
On older schematics I’ve also seen it referred to as /RESET for example (But that’s probably when the schematic software didn’t support the line above)

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.