Library modules again


#1

Hi
Can anyone explain in simple terms how I can get all of the github libraries copied into my global library folder on my PC?
I have just re-loaded the program again, removed all the old libraries, copied the latest download of libraries to a local folder and killed the original fp-lib-table.
The setting for Sysmod is C:\Kicad\share\kicad\modules\ in the paths. I asked the Wizard to do its stuff by selecting all the folders in the downloaded Github libraries (on my computer option selected). It then validates 91 libraries and asks me to review and confirm changes**. Press Next and the “To global library” option is selected. The manager then shows item 1 to 83 as being Github type whilst 84 to 91 are Kicad types despite all being shown as kicad type at point ** above.

I have copied the fp-lib-table.for pretty from the templates folder which then shows everything as being Kicad type but the last 7 are in a different location to the Kicad folder.

I am at a loss as to how to force the Wizard to put the libraries where I would like them, or even so can make sense of them. The modules folder I asked for the libraries to be in was empty.

In frustration, I copied the folders from the download into that folder and tried to add them again. They still remain as Github type.

It seems crazy that the fp-lib-table does not agree with the selected location in the path settings, although it does show the libraries as Github type, except for the last 7 as above.

I like Kicad and have used the old stable version since it came out in 2013, but the library issue with the updated versions makes it un-reliable as every new release seems to have yet another problem with library loading.

Do I have to edit the fp-lib-table manually, as the path setting just seems to be ignored?


#2

If you are talking about footprint libs, this post by @bobc gives a nice step by step explanation on how to get local libraries:

There is a save local copy checkbox.
If you select it you can enter a directory of your choice as the location where your libs will live from now on.
This directory needs to be writable by your user. Otherwise your operating system (windows) will not let you do what you want. This has nothing to do with kicad.

The only thing you probably need to to first is delete the old entries from the fp-lib-table.

By the way your personal lib table is not located in c:[something]\kicad\share\templates but somewhere in your user folder. (I don’t use windows. I have no clue where this stuff lives in windows)
The one in c:[something]\kicad\share\templates is the one that gets used initially when your user does not yet have one in his user folder. It gets copied there. (There is even a message about there not beeing one and that the default table gets copied)

But you don’t need to know where your personal fp-lib-table is located. Just use the library manager to edit it.
(Step 4 of description by @bobc )


#3

Hi thanks for that. The save locakl copy box was checked and all the module libraries were downloaded to C:\New_libs\

It was getting Kicad to accept that they were available locally as Kicad types, as the File Manager insisted that the first 83 were Github type, as did the fp-lib-table, even though the Environment path is set to point to the C:\Kicad\share\kicad\modules folder.

I have since copied all the module files again into C:\Kicad\share\kicad\modules, selected the lot after replacing my fp-lib-table with the fp-lib-table.for_pretty (renamed by losing the .for_pretty extension), ran the wizard and this time it worked, I have no idea why it worked this time but failed about five times before!

For windows7 users at any rate, the fp-lib-table that is used lives at C:\users"username"\AppData\Roaming\Kicad\fp-lib-table.

It can be edited with notepad++, but working out what to change would be difficult without so9kme in depth knowledge of how the file is used.

Anyway it is working for now.:grinning: