Library madness [linux]

Hi there. I’m new in KiCAD but I’ve worked with electronics long time. I decided to change from Eagle but… The libraries are so… I don’t even know how to describe this phenomenon.

I’ve created new footprint and 3D model for big square-shaped bridge rectifier. Everything work good until I try to add this peace of work to library base in KiCAD. After several approaches and big pain in the ass I’ve found that I have to run KiCAD as sudo user (linux stuff) and then I’m able to successfully do this. But it’s not the end of my troubles. After several hours of searching forums, watching youtube and huge load of frustration I’m not able to find my brand new footprints in CvPCB. It just doesn’t exist. I have even tried looking for manually part by part. There is just nothing more than standard library footprints… I’m going to cross oneself with my left leg now.

I’m strong motivated and heavily stubborn man so I’m real guy who can contribute KiCAD community but I have to at least start with some shit.

Can somebody help me? What’s wrong with my KiCAD version? It’s newest release from stable repo.

I’m a new user, but if you have to run as superuser to add a part to the library you are probably trying to add it to an existing library that you don’t have write permissions to as a normal user. You can change the permissions on those libraries, but what you really want to do is create a library of YOUR stuff. You can have a general library if you are going to reuse the parts in other designs or just a project specific library if this is the only time you will use the part.

If you make your own footprints, don’t put them in an existing lib. Make your own library in a folder where your operating systems user has write access. (usr/share/kicad is not a good folder for your own libs!)

I have a kicad library folder placed in my home directory. (This folder holds directories for symbol, footprint and 3d model libs. These folders than hold the .pretty and .3dshapes subfolders.)
For 3d models i take the shortcut of creating symbolic links (created with my super user) but a better way would be to use a personalized path variable. Just create a new variable in the kicad main window->preferences->configure paths and use this in the 3d path of your own footprints.

If you want your own symbol libs to be automatically added for each new project you need to add them to the kicad templete project (located in usr/share/kicad… And yes for this you need sudo rights)
Otherwise simply add your symbols to each new project you create.

Footprint libs are easy to add with the library wizard. Just tell it that you want to add local files.


The “on-stock” KiCad libraries should stay untouched. When new KiCad or library packages has been released your changes will be lost.

You should create your own library/libraries in your home directory and add them to the project(s) you are already working on (if needed). If you’re 100% sure that your symbols or footprints will be used each time, you could include your schematic libraries in default project template: (from /share/kicad/template) and footprints libraries in global fp-lib-table (in ~/.config/kicad). Footprint libraries are easy configurable via included wizard.

And, yes. The KiCad manual should be more verbose about that, and written from a user point of view! But, unfortunately the doc team is smaller than library team.


The same also applies to Windows, create your own libraries and pretty directories in your User directory, not in Program Files


Thanks guys! Actually I’ve never tried to merge my library with the standard ones. I’ve just created my library in project folder. This is definitely problem with KiCAD itself because I’ve done the same thing on my laptop computer and it works.

Now I’m going to erase everything KiCADish from my PC and then reinstall it.

Even though I still can’t add 3D models associated with footprint. 3D wizard seems to work properly but after that footprints are not displayed with 3D option. It looks like KiCAD doesn’t know that footprint “a” corresponding to 3D model “a”. It display just empty footprints in 3D view. Does anyone know simple method to deal with it?

I have some new problem:

“You do not have write permissions to save file /home/dxr/kicad/boostConverter/switch.kicad_pcb.”

Can you believe it? I don’t have permissions to write file in my home directory. And it’s file I created 5 minutes ago. I’m going to never close KiCAD because I can’t save my work. Just shoot me now :slight_smile:

The obligatory - how the libs work - so we all talk the same language:

Personally I have an extra hdd on my machine (but you could go with a separate partition on the same harddrive your program/os folder exists) where I keep all my user data.
I don’t keep data with the programs nor in a home or user folder.

Did you CHECK that 3d model in Freecad or some other tool to make sure it’s actually there and works?
Most models from parts manufacturers are way off the 0,0,0 position and will not show in KiCAD due to this.
You’d have to find their position and adjust it… sorry.

And yeah, that’s why the people doing the KiCAD models put them at 0,0,0 oriented so there is no further messing needed in KiCAD, which then makes it look easy if one doesn’t know this :wink:

What are the permissions/user you start(ed) KiCAD with and does this user have write access to to your home directory?

I’ve started KiCAD normally. Even though every Pcbnew file has sudo access permission. I can’t even delete it without using terminal.

My 3D models are ok. Other models doesn’t work too.

I followed this advice:

and now KiCAD crashes every time I try display 3D view. But didn’t give up. I think I need to read manual ones again, follow the instructions and make some notes to spot the issue.

I haven’t found similar problem anywhere described so maybe if somebody hit this wall then doesn’t even ask for help and simply give up right after first run. Maybe I’m not super duper badass programmer but I know computer-programming and CAD stuff so there is small probability that I screw it up every time I try.

I never need to use sudo rights on my Ubuntu KiCad installations, except for the actual installation, so something is not correct

1 Like

Yeah… exactly. I read all advice here and tried many ways. This is what I’ve found out:

  1. After fresh install run KiCAD and start any project. It doesn’t matter what kind of project you choose. This step is only because you are unable to run Pcbnew without any project started. Just open and save empty project.

  2. Exit KiCAD completely and then run it again as sudo user (from command line).

  3. Go to Pcbnew and open Preferences -> Footprint libraries wizard -> tick Github repository and click next
    Wizard will update footprints and save it on your disk. If you aren’t sudo user then you’re unable to do this step.

  4. Repeat this process with 3D shapes library downloader

  5. NOW VERY IMPORTANT STEP. Exit completely from KiCAD. If you start any project or do modification to existing project as sudo user you’ve been f**ked up.

After that run KiCAD as normal. There will be almost all footprint and 3D shapes of most popular elements.

If you want to create and use your own libraries then if you do it as normal user then you have to load it every time. If you want to add it permanently then you should run KiCAD as sudo while do this. It cause new problem because since then you can’t use it or modify as regular user. You have to cd to directory of your library and chown whole folder. Now you are (almost) happy KiCAD user!

I use Ubuntu 16.04 LTS with xfce desktop environment.

You can do this step as normal user. Either do not enable save local copy or give it a location where your user has write access.
A comprehensive tutorial for local setup can be found here: (In step 9 choose a directory with write access. I would use somewhere in your home directory.)

Again. Give this downloader a directory where your user has write access. And set the KISYS3DMOD variable accordingly. (Kicad main window -> preferences->configure paths)

You really only need sudo to edit the template project to add symbol libraries to all new projects. (It might be possible to move this stuff to a user writable place. I never tried this.)