Library is not writeable (custom) SOLVED

Hi

I created my own custom footprint library long time ago…
But of today I cant save/update/create any symbol in it because I get the warning:

Symbol library ‘XXX’ is not writeable, you must save to a different location.

This is my custom created library and not a system library:

What am I doing wrong?

Ps:
Application: Symbol Editor
Version: (5.99.0-7698-gf06a5894b3), release build
Libraries:
wxWidgets 3.0.5
libcurl/7.74.0 OpenSSL/1.1.1i zlib/1.2.11 zstd/1.4.5 libidn2/2.3.0 libpsl/0.21.1 (+libidn2/2.3.0) libssh2/1.9.0 nghttp2/1.41.0
Platform: Linux 5.10.7-arch1-1 x86_64, 64 bit, Little endian, wxGTK, KDE, x11
Build Info:
Date: Dec 20 2020 08:21:22
wxWidgets: 3.0.5 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
Boost: 1.75.0
OCC: 7.5.0
Curl: 7.74.0
ngspice: 33
Compiler: GCC 10.2.0 with C++ ABI 1014

Build settings:
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_PYTHON3=ON
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_WXPYTHON_PHOENIX=ON
KICAD_SCRIPTING_ACTION_MENU=ON
KICAD_USE_OCC=ON
KICAD_SPICE=ON

You should check the file permissions. When did you use it successfully the last time, has something happened on your system after that? Is ‘p’ your username there? Is ‘p’ still the owner of the directories and the files, and do they have read&write flags for the current user?

nothing special regarding file permission:

p~ $ ls -lah /mnt/store/projekte/kicad/symbols/
insgesamt 44K
drwxr-xr-x  2 p p 4,0K 26. Nov 10:26 .
drwxr-xr-x 82 p p 4,0K  1. Dez 08:52 ..
-rw-------  1 p p 1,7K 17. Dez 2018  IRFZ44N.lib
-rw-r--r--  1 p p  430 26. Nov 10:26 kicad_paul.bck
-rw-r--r--  1 p p  430 26. Nov 10:26 kicad_paul.dcm
-rw-r--r--  1 p p  23K 26. Nov 10:26 kicad_paul.lib

“p” is the username and kicad is runnung as user “p”.
Last modification was november last year… I cant remember any major changes
on my system except ordinary arch linux updates… I even did not update kicad itself because it
was build besides the arch package manager.
The only packages that might have updated are:
kicad-library and kicad-library-3d which do not contain any of the kicad executables, as far as I am aware…

Okay, so I looked in “manage symbol libraries” again and pressed “migrate libraries” while my lib was selected.
Then on restart the lib was missing in the list and I re-added it as “kicad_paul.kicad_sym” and as plugin type “kicad”.
Now I can write again into it and save changes.

1 Like

I dont know whats the difference between the *.kicad_sym and *.lib format, maybe kicad_sym is newer…
But it works now. SOLVED!

I didn’t notice that you use 5.99 (the unstable development version). It has completely different schematic and symbol library file formats than 5.1. You should update to the latest nightly build if you want to use 5.99 at all, it would have given a more helpful notice:

And it doesn’t let modify the old format symbols at all to avoid confusion.

2 Likes

Thanks, yes. I did not consider to rebuild the kicad binaries for a too long time… :expressionless:

1 Like