Library file '${KICAD_SYMBOL_DIR}/CPU_NXP_6800.lib' not found

Hi,

Almost new to KiCad, a week ago I did download KiCad 5 and it works directly. But today I did download the KiCad 6 version. Am using a Mac. Drag it to my Application Folder and run KiCad6, but it did give me directly a error notification, unforunate I dont remember what it was but I did click OK. After double click it did shows me the circuit what I did make with V5. So far so good, but then I want to add an Symbol and it did shows a dialog with 3 posabilities, I did choose the default library location, like I did with V5.

But now I get

Errors loading symbols:
Error loading symbol library 4xxx.
Library file ‘${KICAD_SYMBOL_DIR}/4xxx.lib’ not found.
Error loading symbol library 4xxx_IEEE.

I did look at the paths but they did seems normal, they pointed to inside the contents of the App.
To check I did copy them to my location inside the ApplicationSupport…KiCad… Folder. After a restart ff the App stil the same error.

This is on my iMac, the strange thing is that it did work correctly on my MacBookAir.
BTW, KiCad has full disk access
BTW2, When I try to convert the libraries to V6, I get the same message, Lib not found

How can I fix this?

Thank you.

The location of the libraries changed between 5 and 6 - from /LibraryApplication Support/kicad to within the application bundle itself. You still have references to the old location as ${KICAD_SYMBOL_DIR} will be either not set or the libraries that it points to have been removed.

Go to the main project manager and look at how you have your preferences → manage symbol libraries set.

image

Once you have the paths set, you need to ensure that the libraries are loaded using the ‘Manage symbol libraries …’ dialogue.

If you have only just started with KiCad, the cleanest way would be to delete the ~/Library/Preferences/kicad directory which will force the setup wizard to run and get you back to a clean install. Back it up first if you are worried.

My bet is that you probably installed Kicad 5 on your iMac and then upgraded to 6 but you did a clean Kicad 6 install with no prior v5 on your MacBook.

1 Like

Thank you very much, for your reaction.

Both where no clean installs, the MacBook did have the 5 version before. The only thing is that I did overwrite the KiCad folder with th V6 version. And on the iMac I did rename the v5 version KiCad folder.

I did tried the following before.

  1. I noticed the app internal libraries. I did change all paths to that directory before, no luck.
  2. I did copy all the folders to the Documents/KiCad/6 folder. with the path changed to that folder.
  3. I did copy all the folders to the /Library/ApplicationSupport/Kicad/… folder with of course the path changes.
  4. I did copy all the folders to the. ( user ) ~/Library/ApplicationSupport/Kicad/… folder with of course the path changes.

there is one thing I notice that when I browse to the folder I don’t get the last slash like before in the V5 version or you are showing.

The libraries shows up, at the manage symbol library dialog, but when I click or try to update, I get the same error.

The only difference so far is that the iMac has 10.15 and it looks like that it doesn’t obey the path in the path dialog.
Is there a terminal way to get the path that cicada is using intern?

Also I notice that when I did trow way the preferences file, I do get a dialog that quickly get away without any text visible ( not even one second ), the second curios thing is that I get an extra choice in the same menu that can manage a different kind of libraries, the footprint library.
I see it on my MacBook but not on my iMac right after the pref file is recreated.

I will remove everything (yes everything) again and try again.

But in the meantime can you confirm that it should work on Catalina?

BTW, Forgot to mention in post 1.
In the Symbol Libraries manager, I did see that the Library path’s is different, no" KICAD6_…". Like I wrote in post 1, the migration action failed. So I did add the “KICAD_SYMBOL_DIR” path pointing to “/Applications/KiCad/KiCad.app/Contents/SharedSupport/symbols/”. But still no dice.

Thus, different than your library path in the symbol library manager.

Anyway, I did clean/delete everything, even the KiCad version 5; installed v6 and still the same. :frowning:

After a fourth time with the same mentioned actions, it works. However now I did remove all the cache files with the name KiCad in it. So I can start NewYear with a good Path.

Almost, still the menu item for the footprint manager is gone.