Library file kicad_sym not found

I’m working on MacOS Big Sur V 11.1 and installing from gave me that error when I tried to open the Symbol Libraries:

"Library file “/Library/Application Support/kicad/library/4xx.kicad_sym” not found.

Use the Manage Symbol Libraries dialog to fix the path (or remove the library)."

If I click OK it will show me around 100 other missing files, so I have to kill the app with the app monitor. The same error when installing the

I the /Library/Application Support/kicad/library/ I can find only .dcm and .lib files. How to fix that? I need help urgently!

.kicad_sym file is for 5.99, not for 5.1. Have you tried some development version on your machine at some point? You can try to rename the configuration folder and start from scratch, Where are the configuration files (settings, library tables)?.

No, I haven’t tried any development versions. I’ve first installed the ver. 5.1.9 yesterday from the stable page. But I had to clone the kicad-footprints and the kicad-symbols and select the global symbols/footprints files from there. I’m not sure if that could be the RC.

I’ll try to delete the configurations files and start from scratch. Is there a recommended version for Big Sur? I’ll try with the kicad-5.1-unified-20201230-235024-5d8450db46-10_14.dmg.

:partying_face:Happy New Year!

If you cloned from gitlab you’ve got the libraries for version 5.99/6. The official Mac package should have the correct libraries. I think there was some 5.1 testing version package at some point which had the wrong libraries bundled with it. The latest one should be fixed. The 5.1.9 final release version should be fine, too, and it’s the latest official release.

Remove the old configuration and re-install the latest package.

Installing kicad-5.1-unified-20201230-235024-5d8450db46-10_14.dmg. from scratch solved the issue. Looks like working now. Thanks for the support!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.