Library association through CvPcb


#1

I am still trying to get my head around the endless circle of library use. I downloaded the full set of components from github to the modules folder.

I am running windows 7 64bit.

I downloaded the latest stable release version (4.0.4) and was disappointed to find that the older V4.0.2 stopped working as the fp table seems to have been overwritten.

I tried importing the whole project into the new version but any attempt to annotate the schematic gave an error <<missing “)” in the fp table line 2 offset 54>>. I cannot see any issues with the fp table myself.

I am almost on the point of giving up with the new version, mainly owing to the poorly documented and horribly messy method of managing component libraries. The schematic libraries are great and work well.

For anything major I am still using the final BZR 4022 version from 2013, as at least that is reliable and the libraries are fairly simple to access and manage.

In later versions, CvPcb seems to associate some items but not others. The components are there in the library browser, but the footprint view in Ccvpcb is just blank for the same component. Surely it is either there and accessible or not.

There seems to be some missing link between the sections of the program that are incredibly frustrating.
Maybe my paths are not set correctly but there seems to be little or no documentation as to what different paths do or why a specific path is needed.

In simple terms can anyone please explain how to get libraries that are useable from CvPcb to produce a finished PCB.

I am not a Linux savvy person and this needs to work for me in windows.


#2

I’m not really sure that i understand your exact problem. You seem to describe multiple problems mixed together. I try to address all of them.

First problem update from 4.0.2 to 4.0.4: How did you update it? (Sadly i’m a Linux person so i don’t really know what options there are on windows. But maybe someone else can help you if you give more information.)

Second problem:

Can you give us the error message? Without it we really can not help you here.

Third problem

I assume that for some components the rightmost column in Cvpcb is empty.
This may result from your filter settings. This can be changed with the buttons highlighted in this screenshot.

Because you seem to have problems with your footprints, i think you might be interested in the footprint library wizard or footprint library manager.
This two tools can be found in either the footprint editor or pcbnew under preferences.
They can be used to manage your fp-lib-table using a graphical interface.


#3

I never let the installer overwrite my settings… there is a checkbox for that. It’s usually selected. Deselect it.


#4

Thank you for your detailed response.

I must admit that I have never got to grips with the components library in the newer version.
<<First problem update from 4.0.2 to 4.0.4: How did you update it? (Sadly i’m a Linux person so i don’t really know what options there are on windows. But maybe someone else can help you if you give more information.)>>
I installed a second version of KC in a separate folder in C root drive, wanting to keep the (almost) working V 4.0.2 as a backup. (I have had problems before using newer versions).
<<Can you give us the error message? Without it we really can not help you here.>>
I cannot reproduce it as I uninstalled V4.0.4. As I recall it was " Parse error: Expected “)” in fp_table line 2 offset 54" followed by a message from C:\Windows\Jenkins\Workspace which seems to be a fairly regular comment for any error in windows for KiCad.
Examining the table with notepad++ there is no obvious omission.
<>
Your screenshot shows four buttons. I only have three. The right hand one is missing.
Now I am back in V4.0.2 the right hand pane has items associated with it, but I added two extra components to the original board, a resistor and LED. These appear in the LH pane but not in the right. Even if I associate the footprints in Eeschema, they are not transferred to the PCB. In CvPcb they are in the centre pane, but selecting them and clicking “show footprint” in the menu bar gives a blank box. Selecting on the left panedoes bring up the footprint. There seems to be no obvious way to actually select a footprint from the lefthand pane and transfer it to the selected component in the centre pane. Maybe this is down to the lacking right button.

I have to say I am really confused by the whole method of transferring footprints to components in CvPcb.

I have wasted hours trying to get the earlier V4 issues to work, lost artworks, lost schematics and generally got frustrated after migrating from BZR4022.
I will try again to load the new version and re-build the libraries from GitHub onto the PC. I did this with V 4.0.2 more by luck than anything else, as the documentation regarding Windows is not great.

For some reason the footprints are all there but cannot be associated a specific component, and I seem to go round in circles with it.

I do run a Linux version on a RasberryPi 3, mainly to see if it worked any better, but the limitation of the Rpi make it not easy to use and quite slow, however it does work. The library manager does not seem to be any easier, although the files are more accessible.
Regards
Andrew


#5

Hello again Rene,
I have just wiped the previous installation (4.0.2), having saved my work files.
I then downloaded V4.0.4 again and ran the install file. I opened the save schematic and pcb files, and was able to associate the added components with no trouble at all.

Now everything seems to work just fine. All libraries are present and work, export component file works, import component file into eeschema works and updates the CvPcb file as well.
What happened before I do not know unless the remainder of the V 4.0.2 was upsetting it.
I will try to update my old .mod files and see if they work and try importing an old version schematic and board.
Thanks for your assistance.
Andrew


#6

Thanks Joan_Sparky.
I have finally ditched v 4.0.2 and done a clean install of 4.0.4 and now it all seems to work fine.
Maybe the old files were causing issues.
That was never a problem with the BZR 4022 and earlier, as the whole installation was in its own folder and several versions could be kept in case a new unit had different bugs.
Maybe the fp_table being common to both is a problem now.

Thanks for your help
Andrew