Library Appears but not Footprint


#1

I’m running a mac (OSX El Capitan 10.11.6) and Kicad 4.0.7

I’m new to KiCad and I made a few custom footprints and new libraries but I can only see the libraries and not the footprints inside them when I run CvPcb. I’ve spent a few hours trying to get it to work and read most every post and video I could find about it with no luck.

If I type “e” on the schematic part I can see the library and the components in the library a picture of the custom footprint. I can also assign it directly to the part.

When I look in my footprint library manager, in my footprint editor I see the library and look at my PCB Library Tables, I can see the library is present. I can go to the folder where my library is saved and see that the footprint is saved in the correct folder. I can also open and load the footprint, open the correct library and make it active, and save it to the active library, but it still doesn’t appear in when I go to associate parts when running CvPcb. I have also quite and restarted my computer.

I don’t know if when I go to route the PCB if the new footprints will show up (I think it will but am not there yet), but I was hoping someone could suggest why the library shows up but the components don’t when running CvPcb. Many thanks in advance.

Because I’m a new user I can only put one image per post so I will try to make 3 posts with one image each.


#2


#3

If you look at the lower left corner of the first screen shot you’ll see that you have all of the filters turned on. There are three filter buttons on the end of the toolbar.


#4

PS. The above picture only shows the battery cell with an associated part because I assigned it in the component properties in the schematic window. Note how no components show up on the right side when the “815 bat holder” library is selected. When opening other libraries I see the correct components but never with custom footprints that I have made.


#5

Wild thing…I think I love you :slight_smile:

ahhh this solved it. So many hours spent on this, thank you so much!!!