Libraries suddenly disappeared


#1

Hello,

I am a beginner with Kicad (4.0.7 on Ubuntu 16.04.1). I have created my first schematic successfully and then I have assigned the footprints to each component, also with success.

Then I just wanted to make a modification into the schematic and when I opened Eeschema all libraries except one (power) have disappeared. If I hit on the icon to place a new component I get this:

Before this issue that list had many libraries that are now missing. I want to add a potentiometer and cannot find the way.

Any help is appreciated,
thanks in advance!


#2

Open Preferences->Component Libraries and check the libraries loaded into the project.

If you see more libraries than power, and maybe cache, be sure you click on the add component icon and not the add power icon.


#3

Thanks for your answer. I am clicking on the “add component” icon as can be seen in the previous screenshot.

If I go to Preferences --> Component libraries I find this:


#4

There are no libraries loaded into the project, the “Component library files” box is empty. So the behaviour is right.

Add the libraries you need in the top box.


#5

Hm seems you have lost all libs in this project for some reason.

Is it possible you somehow deleted the .pro file?
Did you by any chance update kicad since you created the project? (Or opened the project with a nightly some time in the past.)

For fixing your problem: click on the upper add button and navigate to the location where your libs are stored (should be somewhere in /usr/share/kicad)


#6

Hello, I did not deleted the .pro file neither updated Kicad. I was following a tutorial on Youtube when this happened. Maybe I deleted them in some way I don’t know.

I added the libraries manually as you have said and now it is working fine, thanks!

Just for future reference, the solution was:

  1. I opened Eeschema.
  2. I went to Preferences --> Component Libraries.
  3. I clicked into the “add” button.
  4. Navigated to /usr/share/kicad/library
  5. Selected all libraries and clicked Open.

Now the libraries are back again.
Thanks!


#8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.