Libraries for nightly builds

Hello!
I’m trying to find the default libraries, but apparently they are not downloaded together with kicad nightly update. The manage path utility says for instance that KICAD6_SYMBOL_DIR is /usr/lib/kicad-nightly/share/kicad/library but in fact the library subdir doesn’t exist. Do I have to download them separately?
Thanks,

On my Linux Mint box KiCad-nightly and it’s libraries are installed by default (I ue the js-reynaud packages from the KiCad website.

It is possible however that on other linux distributions the libraries are a separate package and have to be installed separately.

What does your package manager have to say about this?

Mint is Ubuntu based, which is Debian based and uses apt as package manager. Each “i” as the first character on a line indicates the package is installed.

paul@medion:/usr/lib/kicad-nightly/share/kicad$ apt search kicad-nightly
i   kicad-nightly                            - Electronic schematic and PCB design software      
p   kicad-nightly-dbg                        - Debug symbols for kicad                           
i   kicad-nightly-demos                      - Common files used by kicad                        
i   kicad-nightly-footprints                 - Kicad footprints (modules)                        
i   kicad-nightly-libraries                  - meta-package for dep to all KiCad libraries (symbo
i   kicad-nightly-packages3d                 - Kicad packages3d (3d models for footprints)       
i   kicad-nightly-symbols                    - Kicad symbols (schematic)                         
i   kicad-nightly-templates                  - Kicad templates     

I do not fully understand this part of library managemanet in KiCad-nightly. It looks like they put in some hacks to separate the libraries for the nightly version from the KiCad V5 libraries.
For example, I also have a ${KICAD6_SYMBOL_DIR} set to /usr/lib/kicad-nightly/share/kicad/library/ but if you look at the library listings above it, then it uses ${KICAD_SYMBOL_DIR} as prefix for the library locations. But those are the KiCad V5 libraries.

A search for a random library (“Amplifier_Instrumentation”) finds the libraries for KiCad-nightly (with a different extension as specified in the library table!) in “/usr/share/kicad-nightly/library”

paul@medion:/usr/share/kicad-nightly/library$ locate Amplifier_Instrumentation
/usr/share/kicad/library/Amplifier_Instrumentation.dcm
/usr/share/kicad/library/Amplifier_Instrumentation.lib
/usr/share/kicad-nightly/library/Amplifier_Instrumentation.kicad_sym

So I suspect that ${KICAD6_SYMBOL_DIR} is not used (or has some other purpose) and that ${KICAD_SYMBOL_DIR}, which according to KiCad / Preferences / Manage Symbol Libraries points to /usr/share/kicad/library is silently replaced by the path: "/usr/share/kicad-nightly/library’.

Hello!
Thanks for your reply.
I tried, and here is the output. But it doesn’t specify where the libraries are installed.

Same question as in my other post, but how do you display the output of a terminal?
I checked with all the icons of this editor, and finally I decided to take a snapshot.

Thanks,

Euhm, look at the terminal? It outputs text in itself.
You probably meant how to copy & paste text from a terminal. I usually just press and hold the left mouse button and drag a box around some text. Then release [LMB] and press [RMB] ans select “Copy” from the popup window.

image

The normal key shortcut for copy does not work here, because those key presses are send to the terminal instead of interpreted. There are many different terminal emulators for linux though. From simple and compact to large with lots of added functionality.

Another way is to redirect output of a single command to a text file with the > character. And then do whatever you want with that text file. For example:

paul@medion:~$ ls > boo.txt
paul@medion:~$ cat boo.txt

Your screenshot shows that the libraries are installed. They likely are at the same location as the library paths I captured from a terminal and posted earlier.

KiCad itself does not search for libraries, but only uses libraries that are listed int it’s library tables. The first time you start KiCad (or KiCad-nightly) it asks you if you want to create these library tables, and if you click no, then KiCad does not generate these tables and you can not use any libraries in KiCad-nightly, unless you make your own library tables.

I just moved the config to some new direrectory:

paul@medion:~/.config/kicad$ mv 5.99 asdf_5.99

And then start kicad-nightly from the “start menu” and it asks me again how I want the library configuration:
image

Hello!

Euhm, look at the terminal?

No, what I mean is that even if I copy from the terminal, with the method you indicate or whatever, then if I copy it into this editor, it simply doesn’t work. Example with what I had when I asked this question:
If I paste the output in a text editor, for instance gedit, it works. Not in the current editor.
I tried a few times… And it’s late

Well anyway I read somewhere, months ago, that it’s a good idea to use a copy of the libs so that
they don’t change all the time, so I have downloaded the 5.99 libs and copied them locally and set the path accordingly. It works fine now.

Thanks,