Libraries are empty

Installed KiCad V5 a few days ago and had a discrete schematic drawn in just a few minutes. But there was a problem while browsing the footprint libraries…some of them were empty. The Library name would be there but the footprints would be missing. I saw “Library does not exist” error several times while trying to find the footprints.

Found after an internet search that by renaming the libs with the missing parts from ThroughHole to THT brought the parts back. After further research, discovered that I’d missed installing the libraries for V5 at the bottom of the V5 download page so wanting to be current, I did that.

And that made things much worse. Now, MOST of the libraries footprints are missing…empty. And no error code. They just don’t exist as far as KiCad is concerned. This is also true with PCB. No footprints.

Anyone know where I went wrong?? Thanks!

Did you have a previous install of Kicad 4? If so, you may have still been using the old, Kicad 4 libraries.
There is an FAQ section which might help.

No, as I said I installed V5 a few days ago…but did not notice that there was a download for Libraries at the bottom of the download page. So what I got was V5 and whatever default footprints INSTALL gives users.

This is my first installation of KiCad so there’s no V4 on my machine.

I use Ubuntu 16.04LTS with Cinnamon and used the Shell to install KiCad.

Using the KiCad download page for Ubuntu, what I did was “sudo apt install kicad-footprints”. That’s shown at the bottom of the page. After installing that, now my libraries are mostly empty of footprints.

In PCB_New, I can try to place a part footprint, and get this error (it goes on forever so I only copied the first few):

Errors were encountered loading footprints:
Footprint library path “/usr/share/kicad/modules/Capacitors_SMD.pretty” does not exist
Footprint library path “/usr/share/kicad/modules/Buzzers_Beepers.pretty” does not exist
Footprint library path “/usr/share/kicad/modules/Buttons_Switches_SMD.pretty” does not exist

I see what the problem is, the libraries have been renamed in the software, but whoever handles the Ubuntu setup didn’t change them in our libraries. So what I have in the modules directory is, for example, this:


And it should be “Capacitors_SMD.pretty”.

I can’t just change the names because they are write protected so the KiCad guys need to fix the Ubuntu libraries.

The version 5 libraries are all ‘singular’ i.e. Capacitor_SMD, Package_DIP etc. If you have ‘plural’ forms e.g. Capacitors_SMD, Housings_DIP these will have come from a Kicad V4 library install. Your install seems to have some parts from 4 and some from 5. The FAQ linked previously gives some advice on dealing with this this. Did you follow the instructions from the install page ?
Is your ppa up to date ?

I did follow the instructions for Ubuntu on this page: - the same page you posted.

The instructions for installing KiCad using PPA don’t work with Cinnamon (no ‘Edit’ available in Software Manager) so I used Shell instead and C&P’ed those entries exactly as shown on the Ubuntu download page. As I said, the first time I installed V5 from that page, I missed the instructions about installing libraries using ‘sudo apt install kicad-libraries’ (instructions at the bottom of the download page) so I got the DEFAULT libraries for V5 Ubuntu. Of which there were like 3 that I renamed from ‘ThroughHole’ to ‘THT’. Which brought the footprints back. (I did not check PCBnew footprint libraries though).

Then discovered I’d missed the instructions for adding libraries at the bottom of the download page so did that. That’s when things went bad and now MOST of the footprints are missing.

I have V5.0.1, fresh install, never had V4 installed, and KiCad software currently tells me that the footprint library path is "…/…/Capacitors ". But you’re saying it’s suppose to be “Capacitor”? BTW: All the downloaded footprint libs are singular.

OK, how is that possible that KiCad has it wrong in the software?

I’m going to try to uninstall it and try it again.

Will not really help. The library setup is part of the user configuration files. The installers have no way of touching them.

Even if you never had v4 installed your symptoms look as if you had. This means the solution that helps people who updated from v4 should also help you: I had KiCad 4 installed previosly. Now i updated to v5. Now i have some problems with the library setup (For convenience a attach the link again here.)

1 Like

Trying to follow the directions in that link, I’m in Footprint Libraries, under Preferences:

“Delete all old libs from the lib table (the ones starting with ${KIGITHUB}”

Problem is that there aren’t any libs with that header, mine all say KISYSMOD. There are 74 of them. They are all plural.

Should I still delete them? And I’ve tried to edit the libary paths in there, but the edits won’t take. Changed ‘Capacitors’ to ‘Capacitor’ and it won’t save it after clicking OK. Don’t see any obvious way to delete any either. Perhaps I’m in the wrong place?

If you can figure out where on your Ubuntu system the configuration files are kept (might be in ~/kicad/ or something like that) and while KiCad isn’t running delete the sym-lib-table and fp-lib-table files from that folder (or just rename them). Make sure that you have KiCad and both libraries properly installed. Then when you next start KiCad it will notice that the library table files aren’t in the settings folder and should copy the default table files for the installed libraries.

If the libs are not from github but still are from the old version then you installed the wrong library package. You either need to manually download the version 5 libraries or install the correct version of the library packages.

For the manual solution take a look at this: How can i install a specific version of the footprint library?

A couple points:

I didn’t install the wrong packages, KiCad did. I used their install system and followed their instructions.

This is a brand new installation of KiCad.

Linux Distributions

What processor does your computer have?

ASUS Mobo with AMD Quad Core. 8GB RAM. 500GB SATA HDD. Single boot. Been using Ubuntu for over 4 years now. Have another Win7 machine with all my CAD software on it and was hoping KiCad would be good for schematics and PCBs on Ubuntu. My first couple hours with it did seem pretty good, intuitive like. But with my luck I had to download it when it’s going through an upgrade and library change. Gah!! I’ve seen with other CAD packages how screwed up a library overhaul can be…not fun for the users. Probably not fun for the software engineers either.

KiCad has no package manager. So kicad can not install stuff!
Under ubuntu there is the tool called apt which is what does this installation. (I assume you meant that when you talked about using the command line.) The user needs to tell apt what to install. In this case which version of the library.

The version 4 libs are in the ubuntu default repos. (This is because version 5 was not released when the latest ubuntu had its feature freeze. For older ubuntu versions it would not even be possible to get newer versions of kicad into the official repos.)
The version 5 ones are in inofficial repos. (The ppa you need to install) This is why it can happen that you install the version 4 stuff. (apt will list both the version 4 and version 5 library packages. They have very similar names. They do not have kicad as a dependency as it is a legitimate usecase to have version 5 running with version 4 libs.)

I would suggest you take my advice and simply do a manual install of the libs.

Short version of the explanation:

  • Download the symbol, footprint and possibly 3d models and template libs from
    • place these files somewhere in your home directory.
    • Alternatively you can use git to do this. (will make future updates a lot less data hungry. Makes switching between different releases easy.)
  • Remove all libs from the library tables using the library managers (both symbol and footprint side)
  • Manually add all libs from the freshly downloaded files
    • in the library managers there is a browse button. Click it.
    • You get a tool similar to a file browser. Navigate to the location of your libs
    • select the ones you want to add (shift plus click for area selection and crtl plus click for adding or removing single files from the selection)

To be more exact “kicad-library” is in the official Ubuntu repository, at least for U7.10, and “kicad-library-all”, “kicad-libary-footprints” etc. are in the ppa for KiCad 5.0.

@Jim_HiTek: You can try to uninstall kicad-library and install kicad-library-all. Then, if you don’t mind starting from scratch, delete ~/.config/kicad. Then start KiCad 5.0 again.

1 Like

So semantics got in the way…but again, I didn’t install any wrong packages, I followed KiCad’s instructions on installation of V5 of KiCad for Ubuntu, link previously posted. Which means that anything that got installed wrong was by KiCad’s instructions at that link.

Moving on, I’m going to give up trying to find a simple method (software update or something) of fixing this and try your method.

I don’t mind starting from scratch…I only have one schematic of 7 discrete parts created. Already printed it out and have deleted everything associated with it so when I open KiCad it’s like brand new.

Now going to try to delete ~/.config/kicad and start again. This, along with Rene’s suggestions, are my next moves.

Oh, wait. Ubuntu’s version of KiCad doesn’t have a config folder.

Make sure you enable the showing of invisible folders.

OK, found it. Do I delete the entire folder, or everything inside of it?