Language on Debian Buster stuck in Spanish

Hi to y’all
Problem: cannot change es_PY to en_US. English is the only locale I use. No Spanish on my system.
On my Debian Buster installation everything and all is in English. I started Kicad for the first time and it came up in Spanish warning me that it can’t change to en_PY (I’m located in Paraguay).
What the heck!?
Of course it cannot change to es_PY because I don’t have it installed. I’m using en_US (UTF8) and once in awhile en_GB.
OK, I try to change the language in the menu to English. Kicad again warns me that it cannot change to es_PY and refuses to change to English.
I installed the es_PY locale just to try another approach.
Nogo. Still “cannot change to es_PY” and no way to change to en_US.
Am I crazy? or is Kicad?
There is no Spanish locale on my Debian Buster installation.
I expect application software to respect my locale settings and not to do some weird geolocation or listen to my neighbours.
There are many languages spoken in Paraguay e.g.: Corean, English, German, Low-German, Guaraní, Japanese, Polish, Russian, Toba, Ucranian, … and last but not least Spanish. How can anyone guess correctly which language I prefer?

Any hint for a workaround or how to prevent Kicad from looking up my location would be very much appreciated.
Cheers to all
Eike Lantzsch ZP6CGE

Pretty sure this has nothing to do with geolocation, listening to your neighbors, chemtrails, Roswell or Illuminati.
Are you sure you don’t actually have es_PY set and it’s just that everything else falls back to C?

That aside, being unable to manually set the language seems to be a bug.

What does the command locale in command line say?

I use Kubuntu and Kicad from the ppa, not from the official Kubuntu repo.

My system locale is Spanish es_ES.
I use mostly Kicad in English (though I was one of the translators to Spanish) but I often switch from English to Spanish without any issues.

Kicad does not have a kicad-locale-en package, as it is the default built-in language and there is no difference between en_US and en_UK .
There is only one package kicad-locale-es, no matter the country. This could be the reason (I’m not sure) why Kicad cannot switch to es_PY, as Kicad maybe searchs for a es_ES system locale.

In your case, try to uninstall the kicad-locale-es and see what happens.
Check your regional system preferences too, just to be sure you do not have any other system locale installed than English.

~# locale
LANG=en_US.UTF-8
LANGUAGE=en_US:en
LC_CTYPE=“en_US.UTF-8”
LC_NUMERIC=“en_US.UTF-8”
LC_TIME=“en_US.UTF-8”
LC_COLLATE=“en_US.UTF-8”
LC_MONETARY=“en_US.UTF-8”
LC_MESSAGES=“en_US.UTF-8”
LC_PAPER=“en_US.UTF-8”
LC_NAME=“en_US.UTF-8”
LC_ADDRESS=“en_US.UTF-8”
LC_TELEPHONE=“en_US.UTF-8”
LC_MEASUREMENT=“en_US.UTF-8”
LC_IDENTIFICATION=“en_US.UTF-8”
LC_ALL=

as I already wrote …
thanx anyway

Thank you for your kind answer.
“try to uninstall the kicad-locale-es and see what happens.”
There is no kicad-locale-es package on Debian and I don’t have any installed.
My guess now, according to your answer is, that the Debian maintainer of Kicad already bundled the kicad-locale-es into the kicad package because he is located / a native speaker of Spanish?
In that case I’m going to investigate deeper and take my plight to the Debian-User mailinglist or to the maintainer mailinglist.
Thank you for all your kind replies and kind words!
Besides: There is a difference between locales (tty-consoles) and the X-window. I also checked the language setting of X-window: There is only American English (default) and German.

I think that the problem is not upstream Kicad but indeed the Debian packaging but have to investigate to make sure I nail the correct “culprit”.

Thanx again Pedro and eelik

yes, seems to be a bug of the Debian Buster package …

I’m still curious. What does locale -a show?

In any case I recommend to install Kicad from the ppa as it is the most recent version. Being a Debian user, you already know that Debian packages are always behind looking for a robust system.
Kicad evolution is very fast, so the latest stable version is stronger than any previous one.

~$ locale -a
C
C.UTF-8
en_US
en_US.iso88591
en_US.iso885915
en_US.utf8
POSIX

What about starting kicad from command line with

LANG=en_US.UTF-8 kicad

2 Likes

Thank you but ppa is a nono for Debian installations. I don’t want to end up wirth a Franken-Debian :wink:

I tried Kicad on a Debian unstable installation on a virtual machine.
Kicad correctly comes up with its default: English.
I’m OK with that. Now I can draw my little project and be done with it.
Please don’t bother anymore with my complaint. I just need to get the schematic-job done to get back to soldering :wink:
If I find the time I’ll investigate later to see what went wrong with my workstation installation or the Kicad package for Buster.
Thank you all!

Gorgeous! That works like a charm.
Thankyouthankyouthankyou!

2 Likes

To all who kindly helped:
Please consider this issue as closed.
The problem persists on Debian Stable (Buster) 10.2 with KDE Frameworks 5.54.0; Qt 5.11.3 (built against 5.11.3) and Kicad 5.0.2.
The cause is KDE being configured for Region es_PY but with language etc. configured with en_US.
IMHO no application should pick-up region for language.
One also has to keep in mind that language and region settings for console, for XORG (X-window) and the desktop environment are three different stories. One can be different than the other.
But:
I installed Debian Testing on a virtual machine with the same language and region setup as my Debian Buster workstation. Kicad 5.1.6 (which is in Testing) does not show this odd behavior but correctly comes up with English menus.
It also works correctly on Debian Unstable (Bullseye) and Xfce 4.14.
Consequently if the problem does not exist in the newest releases I think nobody should waste their time anymore on this matter.
Problem solved.
Thank you for all your kind help!
Eike

3 Likes