Label Increment : Not occurring

Whether I am using duplicate or copyPaste, my labels do not increment.


Per my KiCad settings, label increment is 1:


Per this quote:

incrementing should be possible.

Auto increment only works during creation of new labels.
I used it to create the column of labels directly connected to the driver IC.

Then I manually created the “RGB” blocks by making a copy of the big columns and sorting them in a different order.

Try this:

  1. Press lower case “L” to create a label.
  2. Give it the name “itsko1”.
  3. Place it somewhere.
  4. Press the [Ins]-ert key a few times.

This results in a column of numbered itsko labels:

KiCad is just a computer program. It can’t look into my mind to see in which order I want the RGB labels sorted.

1 Like

I want it all!

:wink: :heart:

Despite the cold, demanding language I’m using on these forums, I love the program and the labors of the teams of folx, developers and earnest proactive community both, behind it ^ . ^


I also say the above with Insert having been tried and also not worked, but it’s placed in a weird spot on my bluetooth keyboard as a combo button.

I saw no mention of Insert as a hotkey (do you know if there is a function tied to Insert on the Windows version)? And I am also now in the process of trying to track down whether pressing Insert is actually registering as Insert…

Instead of posting emoticons, press the silly heart.


For me it does not matter much, but for beginners it unlocks some features and disables annoying automatic spam filters.

Oh, wait, you already found that button:

Just continue as usual :slight_smile:

I don’t use Windoze, so I don’t know.
You can view (search through, re-assign, etc) all shortcut keys via: Preferences / Preferences / hotkeys

Same, I’m macOS.

Stated here, there’s no Insert key. This checks out:

CMD+D is listed with duplicate, but it doesn’t increment — there’s only a Duplicate and Increment in PCB Editor: