KIWI Length Matching plugin

when i klick on the icon i got this error

I would guess the plugin isn’t ready for KiCad v7 (which hasn’t been released yet).

i try it on v6.0 , the same problem

Looking at the Video for that Plugin, suggests it’s nothing more than Kicad’s defualt Net-Inspector tool: Menubar: Inspect>Net_Inspector
(screenshot below)

If you want something different, consider my Plugin tutorial as a second starting point (requires some homework but, not much…)

what should i do , change the names?