3D models are managed in a different way than parts and footprints.
The formers have paths defined through internal variables pointing to them. The part paths (libs) can be easily modified from within the preferences.
The foorprint paths can’t be modified for some reasons (greyed entries).
The module paths are hardwired within the footprint files with a path defined as a variable in the same way as the parts and foortrints are but there’s no similar association process.
From my understanding, this makes a bunch of inconsistencies so the first question:
Why are “kisysmod” ans “kisys3dmod” greyed and made not editable ? I tried to force the internal variables by system ones defined in Windows but it doesn’t work.

I searched the web and carefully read Library management in KiCad version 5. Unfortunately it doesn’t provide me with any clue related to my configuration.

Libraries are quite huge, more than 5 Gig ! and I don’t intend to duplicate them over the disk. As part of my disk reorganization, I want to move the 5.1.2 legacy libraries from the installation path to my specific directories, let say: D:\P_libraries\legacy\library, …\modules, …template, …\modules\package3D. For information, under D:\P_Libraries, I have also some other subdirectories containing my own parts, footprints & 3dmodels as well as downloaded and/or converted ones. So that the navigation, the file sharing and the backup operations are easier for me and risks to overwrite the genuine libraries is nil.

I, first modified the kicad symbol path under “preferences” and, since kisysmod & kisys3dmod are not editable, two new user paths for the footprints and the 3D modules were created.
For the footprints, it was a little bit more tricky, I had to backup then edit the “fp-lib-table” file and change with a text editor all the “kisysmod” occurrences by “user_kisysmod” pointing to my new legacy footptint directory.

No major issue with the few 5.1.2 existing projects after I edited the “.kicad_pcb” files with a text editor, replacing “kisysmod” by “user_kisysmod”.
However there’s a big annoyance: the hard-linked 3D models in the footprints. For a very few number of parts, the footprints 3D Settings might be modified; pointing to D:\P_libraries\legacy\modules\package3D but for a larger number of parts this would be tedious and need to be done everytime a footprint is used again. Moreover, I wouldn’t like to modify the already existing footprints. The sole way seems to make “kisys3Dmod” editable.
This typically what I’d like to do:

** How to do it ? **

Thanks in advance

Because you somehow set them outside of kicads control. Most likely in the windows registry. (Did you perhaps select the “environment variables” option of the windows installer?)

1 Like

Hi Rene,
thanks for your prompt reply.
Not at all, this is a version made portable, there’s no occurrence in the registry, I checked it again.
Hovever your reply trigged the idea that it might be the portable launcher that was the culprit and it was !
Launching the normal kicad.exe file, the two variables can now be modified and in pcbnew 3D-settings box the modules are well under the expected path.
I’ve reverted all my mods as well as the paths in fp_lib_table and in the kicad_pcb files. Everything is workind properly. Sorry for the noise.
The issue is fixed, the thread can be closed. Thanks again.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.