Kipart place reverse order for pins on the right side

zturn_lite.csv (4.2 KB)

Hi, I want to create a component using kipart, the pins on the left are numbered 2…110, and the pins on the right are numbered 1, 3, …, 119, However when I use the -s num options, the pins on the left are sorted while the pins on the right are sorted in a reverse order.

PS, I am using python3 and the latest kipart-0.1.29 from github. The command regenerating the symbol is

kipart -s num zturn_lite.csv -o zturn_lite.lib --overwrite

Any solutions to this problem?

@devbisme, let’s summon the maker :wink:

Yes, in the kicad nightly build version, the port types are shown, in a relative much smaller font size. :joy:

The sorting you’re seeing is correct. The standard way to arrange pins on a chip is counter-clockwise, starting from the upper-left corner. So your left-side pins proceed 2, 4, …, 110 on the left side and then start at the bottom of the right side with 1, 3, …, 109.

But you don’t care about that. You just want your pins in the order you want. The easiest way to do that is to use the -s row option which places the pins in the order of the rows in your CSV file. So you should arrange your pin data in the spreadsheet as:

   2   P5_R51_OUT   left
   3   IG_B35_LP3   left
110    IG_B34_LN8   left
109    IG_B34_LN7   right
107    IG_B34_LP7   right
  1    EXT_RST_IN   right
1 Like