Kipart not responding

Hi Sir,

I have read the documentation of Kipart, as below link :

Since I already have installed Python in my computer before, I installed Kipart accordingly by command “pip install kipart”

I’ve found “kipart.exe” is installed under “D:\MyPrograms\Anaconda3\Scripts”, then I placed a simple “test.csv” file in the directory, content as below :

23, input, A5
90, output, B1
88, bidirectional, C3
56, tristate, D22
84, tristate, D3
16, power_in, VCC
5, power_in, GND
29, power_in, VCC
98, power_in, GND
99, power_in, VCC
59, power_in, GND

but I am not exactly know how to execute kipart.exe correctly

Firstly, I opened Anaconda prompt window, execute “kipart test.csv”, but nothing happened, I have checked the directory “D:\MyPrograms\Anaconda3\Scripts” and did not find a “test.lib” created by kipart.exe

then I open command window prompt and try again, no luck again

any suggestion would be very appreciated, thanks !

I am using Python version 3.7.4

You need a line containing the name for the part you are creating. It should be above the other lines like so:


Pin,    Unit,   Type,           Name
23,     IO,     input,          A5
90,     IO,     output,         B1
88,     IO,     bidirectional,  C3
56,     IO,     tristate,       D22
84,     IO,     tristate,       D3
16,     PWR,    power_in,       VCC
5,      PWR,    power_in,       GND
29,     PWR,    power_in,       VCC
98,     PWR,    power_in,       GND
99,     PWR,    power_in,       VCC
59,     PWR,    power_in,       GND

kipart should have given you an error message if that line was missing. I’m not sure why it didn’t.

When it runs successfully, kipart should also give you an indication of that:

$ kipart kipart_test.csv
Writing kipart_test.lib 1

I ran this on both Ubuntu 19.10 and a Windows10 VM using Python 3.7.6 without problems. I haven’t used Anaconda so I don’t know what problems that might be introducing.

1 Like

Hi devbisme,

Thanks. I finally got a *.lib output from kipart with a *.csv file exactly the same as yours(example_part.csv), however, when I try to export my own *.csv file(example_part4.csv), there is no *.lib output(no error message, either). I can’t tell if there is any significant difference between the two *.csv file, see below

I also attached the two *.csv files, could you have a look on this, thanks !

example_part.csv (457 Bytes) example_part4.csv (206 Bytes)

All your pin types are set to NA. That isn’t one of the allowable types. I got an error when I ran your file. Then I changed them all to IN and the library file was created.

I’m not sure why you aren’t getting any error messages.

1 Like

Hi devbisme,

I carefully read the documentation again, and found I’ve made some mistakes

  1. the “Type” column only support specified words, if I change to “input” then I can get *.lib output from example_part4.csv
  2. not supported header should be deleted from the *.csv file, and if using microsoft excel to edit the *.csv file, choose “delete column” instead of just press “delete” on the keyboard to delete the content, delete the content only still leave comma in the *.csv file(see below) that prevents kipart to function correctly

Maybe my real problem is no error message output from kipart so there is no clue for me to help kipart function correctly ?

Nevertheless, I just successfully got a Xilinx XCKU085 library(1500+ pins) in KiCad, thanks !

Ah, I wish I’d known you were trying to make XILINX FPGA parts. I have KiPart-generated symbols for all their parts in my KiCad library repo. The part you want is in the xilinxultra.lib file.

Of course, now that you have KiPart working, you can easily customize your Xilinx symbols for your own application.


Hi devbisme,

Problem solved, please accept my most sincere thanks !

1 Like

Did you ever find why kipart error messages were not appearing?

No, there is no output message at all, and I do not know anything I can do to figure out what is going wrong, thanks.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.