KiKit and JLC Fabrication Toolkit failure

I have used KiKit to panelise a simple PCB, and I am then using the JLC Fabrication toolkit to export the production files. I have already used this combination several times, and it has always worked well. However, with this board (which is pretty simple!) the Fabrication toolkit is hanging at about 95% complete. and no matter what I try, this always happens. If I close the progress toolbar, then the production folder is created, but with no files inside it.

Things I have tried so far:-
I have done a DRC check on the individual board with zero errors
I have checked that the individual board produces a successful output through the Fabrication toolkit
I have rebuit the Panel using different combinations of Rows/columns
I have checked that the individual componets present on the board are correctly identified with JLC Part Numbers (indeed, I have already produced a similar panel with an identical BOM)

My Specific Questions are:-

Is there any diagnostic output from the Fab Toolkit
How do I interrogate the Fabrication Toolkit output to identify the cause of the Hang?

Is there anyway of interogating KiKit for problems present in the Panel (running a DRC produces many outputs - mostly due to footprints, edge cut fouls which are not material and which have not caused issues on other projects.

As this is a simple board, it would not be too difficult to just start again, but better to sort the root cause if possible.

Many thanks afor any help offered.

Have you asked here: GitHub - bennymeg/JLC-Plugin-for-KiCad: Fabrication Toolkit - An JLC PCB Plugin for KiCad

Can’t you simply use the KiCad fabrication tools ? Gerbers etc.are accepted by JLC.

Thanks for your reply.
These are populated boards, so gerbers. etc. are not the issue. There is an alternative JLCPCB plug-in which I am exploring, but my question remains - what has stopped this one working in this instance when it works in every other one.

I seem to remember that Benny was waiting for v8 to release an updated plugin. Check the github site.

Many thanks for the contributions.
Just to say that this morning, I got it to work. I just created a new project did the panelization in that, and created the fab ouput and it worked perfectly. Unfortunately, I do not know what was wrong with the original set-up, though I strongly suspect that the plugin was creating the files OK but something was stopping them being saved.
Much as I like KiCad, I find myself throughly confused by how it structures files and sub folders within a new project folder. I have also not found a really good walk-through of a good work-flow toset-up and manage project folders, how to re-name projects, how to delete obsolete projects, how to manage versions, how to re-use files between projects etc etc. And I suspect that my attempts to find a way through all this are screwing things up. I often get messages that KiKad could not monitor a particular(back-up) file, or that a file failed to save (with an “Error code 0: operation completed successfully” !!!). So I am pretty confident that I am the problem here!

Just to say that with a lot of digging about in Windows logs, I found the problem “Path Length Too Long”. Moral of the story (in Windows at least) do not use over-long names for your projects!

It would be great if the plugin-in reported such errors, but I am not complaining - it saves a massive amount of work and for that I am very grateful!

Interestingly, I found other logs of similar errors from KiKad - so it seems that it too encounters the same issue without trapping it.

Best Wishes,

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.