Kifield "unable to write file"


#1

I can’t get kifield to output an .xlsx or .csv file. When I try to run kifield on a design it gives the following result:

D:\Projekt\seq\HW\CAD>kifield -x seq.sch -i seq.xlsx -r
Unable to write to file: seq.xlsx.

Same problem with csv file output.

OS: Windows 10
KiCad: (2016-12-02 revision 54c5f6b)-makepkg, release build

Any ideas? I have tried searching for this issue but found nothing. I know it is a kind of old nightly but I’m waiting for a v5 release candidate before I risk updating.


#2

What are the permissions on that folder? I don’t use Windows much but that sounds like a write permission error. Or space issue?


#3

Thanks for your reply. “Authenticated users” have permission to write in the folder so I would think it should be ok. I have also tried running the console window as administratior with the same result (don’t know if that should make any difference).


#4

Forgot to add: no its not a space issue.


#5

You should not need to be Administrator to run kiCad or any plugin - it is asking for trouble later on.
Paging @devbisme the author. I am suspecting that the problem might be the “D” partition


#6

This is a bug that occurs when KiField is trying to back up a file that isn’t there. Kaspar Emanuel fixed it last week. I uploaded the fix just now. You can pip install the newest KiField and the problem should be fixed. If you want to keep your current version of KiField, just use the -nb option to turn off backups the first time you run it.


#7

Yes, that worked. Thanks a lot!


#8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.