Kicadstepup with flatpak - setup?

I have KiCAD 6.0.5 and FreeCAD 0.19.4 installed on Debian 11 using flatpak. Kicadstepup is installed as per the instructions using the FreeCAD Add-On Manager.

When I import a PCB using the kicadstepup workbench I get an error message that modules are missing:

All of the missing modules are part of the KiCAD library.

Since I am using flatpak, the library is not at the usual /usr/share/kicad/… but it is in the org.kicad.KiCad.Library.Packages3D flatpak.

What path to I use for KICAD6_3DMODEL_DIR in kicadstepup?
Do I need to give FreeCAD permission to access the org.kicad.KiCad.Library.Packages3D data? If so, how do I do this?

I’m not using flatpack, but if your kicad 3d models are in
org.kicad.KiCad.Library.Packages3D
you should add this path to FreeCAD StepUp configuration page…
Please have a look at kicad StepUp cheatsheet pg1 point 4)

I’m not falimiar with flatpack, but in general you should add the same path you use in KiCad for 3d models in FreeCad (StepUp) preferences