Kicad8 step files not found on export

I’ve added 3d models to parts in my PCB. I can see the 3d models when I view the board, but when I go to file->export->step, none of these files show up in the exported step file, and I get a bunch of messages like this:

Could not add 3D model to P3.
File not found: ${KIPRJMOD}/packages3d/B2B-XH-A.step

I’ve verified that kicad thinks KIPRJMOD is pointing at the correct directory, and file permissions look good. I’ve tried several checkboxes on export, including “Substitute similarly named models”. I’m wondering if this is some kind of CLI export bug? and KIPRJMOD is not properly being passed to what’s being run? or maybe it’s not properly expanding KIPRJMOD?

I would appreciate any help with this, it makes collaboration difficult.

the header of B2B-XH-A.step is

‘1’ );
( ‘’ ),
( ‘’ ),
‘SwSTEP 2.0’,
‘SolidWorks 2021’,
‘’ );

KICAD version

Application: KiCad PCB Editor x86_64 on x86_64

Version: 8.0.1-8.0.1-1~ubuntu22.04.1, release build

wxWidgets 3.2.1
FreeType 2.11.1
HarfBuzz 2.7.4
FontConfig 2.13.1
libcurl/7.81.0 OpenSSL/3.0.2 zlib/1.2.11 brotli/1.0.9 zstd/1.4.8 libidn2/2.3.2 libpsl/0.21.0 (+libidn2/2.3.2) libssh/0.9.6/openssl/zlib nghttp2/1.43.0 librtmp/2.3 OpenLDAP/2.5.17

Platform: Ubuntu 22.04.4 LTS, 64 bit, Little endian, wxGTK, X11, KDE, x11

Build Info:
Date: Mar 14 2024 17:17:31
wxWidgets: 3.2.1 (wchar_t,wx containers) GTK+ 3.24
Boost: 1.74.0
OCC: 7.6.3
Curl: 7.81.0
ngspice: 42
Compiler: GCC 11.4.0 with C++ ABI 1016

Build settings:

Further troubleshooting. If I go and change the path in the 3D models to use the full path instead of
${KIPRJMOD}, then the model successfully loads, and is viewable on final exported step.

This, of course, makes it difficult to share kicad projects :confused:

And, I finally managed to find the bug for this. Looks like it’s fixed but not released :frowning: