Kicad2step.exe does not produce anything


#1

Hi everyone.
I’m stuck with the following problem. I’ve completed a Kicad project and want to export the model into STEP format. I go to File->Export->STEP, select any options, click Export, it tells me that the file was generated successfully, however no file appears.
This happens with any option for coordinate origin.
My project uses custom footprints with custom 3D models. WRL files for them were converted from STP and appropriate scaling,translation and rotation applied into footprint editor. Kicad has no information on source STP files.
I’m using official Kicad release under Windows 7.
I’ve tried to launch kicad2step.exe from command line. No new file appears and no output to console.
Do I need to install any other software for it to work properly?
Any help is greatly appreciated.

Application: kicad
Version: (5.1.2)-2, release build
Libraries:
wxWidgets 3.0.4
libcurl/7.61.1 OpenSSL/1.1.1 (WinSSL) zlib/1.2.11 brotli/1.0.6 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) nghttp2/1.34.0
Platform: Windows 7 (build 7601, Service Pack 1), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8)
Boost: 1.68.0
OpenCASCADE Community Edition: 6.9.1
Curl: 7.61.1
Compiler: GCC 8.2.0 with C++ ABI 1013
Build settings:
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=OFF
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_PYTHON3=OFF
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
KICAD_SCRIPTING_ACTION_MENU=ON
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=ON
KICAD_USE_OCC=OFF
KICAD_SPICE=ON


#2

I’ve tried to export with a slightly different version under Debian (testing). It worked normally, just with some warnings.

‘"/usr/bin/kicad2step" --drill-origin -f -o “/home/ill/Disk/osm35s5_pilot/osm35s5_pilot.step” “/home/ill/Disk/osm35s5_pilot/osm35s5_pilot.kicad_pcb”’
Warning:
Warning: (process:17930): GLib-GObject-WARNING **: 20:22:15.228: invalid (NULL) pointer instance
Warning:
Warning: (process:17930): GLib-GObject-CRITICAL **: 20:22:15.228: g_signal_handlers_disconnect_matched: assertion ‘G_TYPE_CHECK_INSTANCE (instance)’ failed
Warning:
Warning: (process:17930): GLib-GObject-WARNING **: 20:22:15.228: invalid (NULL) pointer instance
Warning:
Warning: (process:17930): GLib-GObject-CRITICAL **: 20:22:15.228: g_signal_handlers_disconnect_matched: assertion ‘G_TYPE_CHECK_INSTANCE (instance)’ failed
Info: STEP file created successfully.

Application: kicad
Version: 5.1.2+dfsg1-1, release build
Libraries:
wxWidgets 3.0.4
libcurl/7.64.0 OpenSSL/1.1.1c zlib/1.2.11 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) libssh2/1.8.0 nghttp2/1.37.0 librtmp/2.3
Platform: Linux 4.19.0-5-amd64 x86_64, 64 bit, Little endian, wxGTK
Build Info:
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
Boost: 1.67.0
OpenCASCADE Community Edition: 6.9.1
Curl: 7.64.0
Compiler: Clang 7.0.1 with C++ ABI 1002

Build settings:
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=ON
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_PYTHON3=ON
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_WXPYTHON_PHOENIX=ON
KICAD_SCRIPTING_ACTION_MENU=ON
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=ON
KICAD_USE_OCC=OFF
KICAD_SPICE=ON


#3

If you just need to get STEP models you can import the board file to FreeCAD after you have installed the StepUp workbench. I, too, have experienced some problems with KiCad’s STEP export. Nowadays I use FreeCAD/StepUp routinely for many tasks, although there is of course some learning curve. But it’s not difficult to open the board file and export the result to STEP.


#4

Please raise a bug report on Launchpad


#5

I have been using KiCad native export to STEP lately without any problems in various 5.1x versions; I typically download the latest 5.1 nightly at a few days interval. These are files that include 3D STEP models from a number of different sources - KiCad official, self designed and manufacturer models. I generally use FreeCad StepUp to align and scale models from other sources, so that each model has a scale factor of 1, and there is a pair of .wrl. and .step of each model in the location defined by KISYS3DMOD. I have in one or two instances introduced offsets of a model in Kicad without any problems, but generally also keep offsets at zero. I also sometimes use StepUp to import boards into FreeCAD, so either way works.

The only exception I can think of is where a STEP model was not a solid but a surface (hollow) model. As I vaguely recall the export from KiCad then either failed or was corrupted.

The only general problem I have is that the console window in the STEP export dialog is just one line so that the resulting text is not shown without scrolling.

Application: KiCad
Version: (5.1.2-183-g01a343f28)-1, release build
Libraries:
wxWidgets 3.0.4
libcurl/7.61.1 OpenSSL/1.1.1 (WinSSL) zlib/1.2.11 brotli/1.0.6 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) nghttp2/1.34.0
Platform: Windows 7 (build 7601, Service Pack 1), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8)
Boost: 1.68.0
OpenCASCADE Community Edition: 6.9.1
Curl: 7.61.1
Compiler: GCC 8.2.0 with C++ ABI 1013

Build settings:
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=OFF
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_PYTHON3=OFF
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
KICAD_SCRIPTING_ACTION_MENU=ON
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=ON
KICAD_USE_OCC=OFF
KICAD_SPICE=ON


#6

Thanks everyone for the replies. No need to file a bug as it’s already known:

Step export not working when special characters in filename or path
pcbnew: export to STEP file in non-english file path

Probably these 2 are the same problem.
Moved my project to a simpler path - STEP done.
Was very optimistic for me to forget about these problems as it’s only 2019.


#7

you can even have a try with StepUp and FreeCAD…
your issue should be already handled.


#8

That’s what I said already :slight_smile:

Do I sense a hint of sarcastic irony here? :thinking:


#9

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.