KiCad Window not showing


#1

Hi everybody,

I am running the latest KiCad (4.0.2) on Windows 10. However, the KiCad Window does not show. If I press Alt-TAB to toggle between programs, the window is shown in the preview but not as an actual, usable window. I already had the same issue with 4.0.1 and updating to 4.0.2 helped for a short time - one program start to be precise. I am now stuck with using eeschema and then changing to pcbnew etc. from there.

Is this a known issue?

Regards
Cord


#2

What happen if you minimize and maximize the windows?
Could it be possible that you have multiple screens and it is show on a hide / not used screen?


#3

When I maximize and minimize the windows the KiCad Windows gets the focus (it is highlighted in the task bar) but does not show up as a window. All other windows work normal, only the KiCad Window is affected.

I do have a 2 Monitor setup but the issue persists if I disconnect the external monitor. And I have been using KiCad for several years now on the same hardware and never had the problem before.


#4

KiCAD stores window positions and sizes in the settings files…

I don’t know if the folder is the same for windows 10, but this is the location in windows 7:

C:\Users\JohnDoe\AppData\Roaming\kicad

Open a file called kicad, first lines should be something like this:

KicadFramePos_x=753
KicadFramePos_y=478
KicadFrameSize_x=918
KicadFrameSize_y=568
KicadFrameMaximized=0

Those values make the KiCAD window appear on one screen of a dual monitor setup (2x 1650x1050, side by side) at the lower right - season to taste or ability of your setup :sunglasses:


#5

Thank you very much for the tip: I got my window back :slightly_smiling:
It must have been at some off-screen position. I still wonder how that happened - maybe KiCad was on the big screen (1920x1080) last time and wanted to open with the position on the smaller screen.

Anyhow. I got it back now and know what to do for the future :slight_smile:


#6

I’ve seen the same issue when first working with a docked laptop and dual monitors, then undocking the laptop and opening kicad just on the (smaller) laptop screen.

If possible kicad should probably query the OS at startup about what screens are available - the latest stored parameters from last shutdown are not always the right choice.


#7

On windows 7 (not sure about 10) sometimes it helps to click the tab on the task bar and then press Windows key + Shift + L/R arrow, which moves the active window between the monitors.


#8

You star! :grinning: I’ve had this issue for ages and because I couldn’t get some windows to display was running KiCad in a VM on Windows 10. I’ve posted about the problem many months ago and nobody was able to pin the issue down - old threads led me astray into issues of display drivers.

I used Winlister to check the window was actually being displayed/listed, then used its menu option to centre it on the monitor. Success and problem solved.

Finally I can run KiCad natively on my Windows 10 machine. :relaxed:


#10