KiCad V6.99 keeps on growing the project manager

In KiCad V6 I’m used to shrinking the project manager, because I have more use for monitor real estate then showing the texts of what the main icons do. The project manager looks like:

In KiCad V5.99 however, this does not work. The narrowest I can make this window is:

What is more annoying though, is that each time KiCad V6.99 is closed and restarted, it grows the project manager to it’s default size (KiCad V6 remembers my preference).

I’m not sure what to do with this. I find it a bit annoying, but at the same time it seems silly to create a bug report for this. I am curious though whether I’m alone in this, or if others have similar thoughts.

On my installation v6.99 remembers last project manager size. Can you try to temporarily remove /home/paul/.config/kicad/6.99/kicad.json and try again a few times to see if this changes something?

If not just move that config file back again.

I did a:

paul@cezanne:~/.config/kicad$ mv 6.99 2022-12-31_6.99
paul@cezanne:~/.config/kicad$ kicad-nightly
paul@cezanne:~/.config/kicad$ kicad-nightly
paul@cezanne:~/.config/kicad$ kicad-nightly
paul@cezanne:~/.config/kicad$ kicad-nightly
paul@cezanne:~/.config/kicad$ kicad-nightly

With the same results.
The window gets enlarged to a size where all the text is visible.
KiCad does remember both window location and size, but only if I make the window bigger. When I make it smaller, it’s always reset to a size where all the text is readable.

In KiCad V5 the Icons were horizontal, and I put the project manager on the top of my desktop. Now the icons are vertical,and I normally put it on the far right side of my monitor, so I can keep the icons accessible without loosing much desktop space. But this does not work anymore in 6.99

I did install the latest nigtly for testing this:

Application: KiCad x86_64 on x86_64

Version: 6.99.0-unknown-e9ed56e9a4~164~ubuntu20.04.1, release build

Libraries:
	wxWidgets 3.2.1
	FreeType 2.10.1
	HarfBuzz 2.6.4
	FontConfig 2.13.1
	libcurl/7.68.0 OpenSSL/1.1.1f zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh/0.9.3/openssl/zlib nghttp2/1.40.0 librtmp/2.3

Platform: Linux Mint 20.3, 64 bit, Little endian, wxGTK, xfce, x11

Build Info:
	Date: Dec 30 2022 20:32:45
	wxWidgets: 3.2.1 (wchar_t,wx containers) GTK+ 3.24
	Boost: 1.71.0
	OCC: 7.5.2
	Curl: 7.68.0
	ngspice: 38
	Compiler: GCC 9.4.0 with C++ ABI 1013

Build settings:
	KICAD_USE_EGL=ON
	KICAD_SPICE=ON

The only difference i noticed that might has something to add is that you are on xfce and i am on cinnamon.

I am on commit 5e0064c21e800c (5 commits older than yours), also I do not think GCC 10.3.0 might be more responsible for something like this so i don’t think this makes any real difference.

Maybe someone on xfce can offer some additional testing.

Mint, cinnamon, 20.3 here.

BOTH 6.0.10 and 6.99 behave exactly as @paulvdh 's 6.99

What is your cinnamon version? I am on 5.2.7 and KiCad ( build and installed from source ) remembers its last size even with hidden text…

If the reason in not in a cinnamon version difference, my next thought will be about different theme or settings that might affect this behavior. I cannot dig much deep in that terrain though TBH…

I tested this on Ubunu 22.10 and 6.99 works as expected (remembers the window size)

Do you have a different Preferences/Preferences/Icon-Size on the two versions? I like it set to 75 or so.
I am on ubuntu-based pop-os 22.04 and both 6.0.10 and 6.99 remember pm sizes on open:

Everything working correctly today.

Application: KiCad x86_64 on x86_64

Version: 6.99.0-unknown-bd5d10cd7b~164~ubuntu20.04.1, release build

Libraries:
wxWidgets 3.2.1
FreeType 2.10.1
HarfBuzz 2.6.4
FontConfig 2.13.1
libcurl/7.68.0 OpenSSL/1.1.1f zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh/0.9.3/openssl/zlib nghttp2/1.40.0 librtmp/2.3

Platform: Linux Mint 20.3, 64 bit, Little endian, wxGTK, cinnamon, x11

Build Info:
Date: Jan 4 2023 20:32:50
wxWidgets: 3.2.1 (wchar_t,wx containers) GTK+ 3.24
Boost: 1.71.0
OCC: 7.5.2
Curl: 7.68.0
ngspice: 38
Compiler: GCC 9.4.0 with C++ ABI 1013

Build settings:
KICAD_USE_EGL=ON
KICAD_SPICE=ON

@ paulvdh, I now see what you were saying about the minimum sizes – 6.99 cannot be sized quite as small as 6.0.10. The inner frame can pull the icons in view or not, but the minimum pm width of 6.0 is smaller than 6.99.

I think minimum width depends on the menu bar and there is new “Edit” menu in 6.99 so it’s wider.

1 Like

For me minimum width is about the same, just over 400 pixels, measured with “screenruler”. Icon size is 100% as I have a 107cm 4k monitor with a normal pixel pitch (I don’t believe in that HiDPI rubbish).

But the problem is not with the window size on itself.
It is that KiCad V6 always remembers the width that I set it to, while V6.99 makes the window wider again so all the text fits in the window the next time it is started.

First: Open both V6.0 and V6.99:

Then close both, and open them again:

Now I’m getting confused. Both have now grown to about 850 pixels width.
Both act the same now. If the width is smaller the 850(ish) it grows to that width, if it’s wider it gets remembered.

My 6.99 is different then, as it will start up and remember the minimum size pm window.

But I always have the pm, sch, and pcb all maximized and I just click the kicad icon to rotate through them, so I have never used pm as a tiny window.

Mine were behaving as Pauls, but for some reason, in the last 4 days, they have “magically” corrected themselves, so they now behave correctly. I didn’t notice or check between 4 day old post and current post.

Only change I made is 6.99 (updated most days). No changes made to 6.0.10 or the OS.