Kicad V5 Export to .step issues


#1

Dear KiCad team. First of all, thank you for the tremendous work you did over the years. I’m a 10+ years user of KiCad and love it. Usually on Windows machine, but I find now that the OSX version is mature enough and totally usable.

I was very happy to see that now KiCad can export directly in STEP format which helps me to work with other companies for the mechanical integration. I used to used FreeCAD with “FreeCAD Printed Circuit Board” from Marmni (https://github.com/marmni/FreeCAD-PCB).
However, I saw 2 issues there:

a) The capacitor 0402 STEP file object seems to be too small, and you need to multiply x,y and z by 2.5 to have a coherent object size on the board. But this scaling factor is not kept during the STEP export function.

b) The PCB object in the STEP file looks like a plain cube shape and does not contain any holes nor tracks. Therefore, I cannot see card border connectors.

I did the test with both FreeCAD 0.16 and FreeCAD 0.17 (on OSX)
May be I did not know how to fix these two small issues, can anyone help me ?
I thank you in advance,

Best Regards,

OM.


#2

Are you sure about that? I just checked the footprint of the library tagged with 5.0.0 against the 3d model of the lib tagged as 5.0.0 and everything looks to be correctly scaled:

Is it possible that you have the version 4 footprint libs mixed with kicad 5 3d model libs?
(old footprints had a scaling factor for 3d models as the old models where scaled wrong. So if you have the old footprint on the pcb then the 3d models will not fit. Check that by opening the footprint properties on the placed footprint. If the 3d settings dialog does not show 1,1,1 for the scaling factors then you have the old footprint added.)

It is suggest to install the old libs to handle old projects. (there is no easy way to do this. You will need to manually point the environment variable KISYS3DMOD to the old lib when working on old projects.)


#3

At least with my v5.0.0 under kubuntu holes are exported correctly in the pcb step model.
Tracks are not shown in the step model on purpose. There are other threads in this forum explaining so.


#4

Please consider that nothing get scaled with the exporting process… All 3D models should be at scale factor of 1,1,1.
Scale factor can be used only in 3D viewer for rendering purposes, but it will not be applied to step exporting operation.
In fact the step exporter is just an assembler of pre-existing step models, placed at their positions plus the generation of the pcb board converted to step format.


#5

Hi,
Yes I’m sure. Both versions (Windows and OSX) are clean versions of V5 from the Download page.
I will try to update the 3D library from Github. But it takes ages (we don’t all have a finer connection :frowning: )
I’ll keep you informed.

Regards,
OM.


#6

Hi,
Thanks for the answer, I’ll double check.
I did not find the other threads on the forum regarding the lack of tracks and imagine that this is to remove a certain level of complexity, however, why not give the user the choice with a checkbox in the export dialog box.
I have PCBs where wires shall be attached to border SMD pads and can’t show the location on the STEP model and integrate it in the mechanical view of the final assembly.
I find as well that giving in the STEP file the components reference (R1, R2, C1, C2, etc.) as the objects label would be better than giving them the step model name with a suffix (_1,_2, etc.) due to label repetition.

Regards,
OM.


#7

Where in my post do i write anything about updating the 3d lib?
I said check the 3d settings of the footprint!


#8

Hi,
Thanks for the answer. I understand, however, the various other parameters (rotation, offset) are used in the STEP Export, why not give the ability to the user to export using the scale factor using a checkbox in the STEP Export dialog ?

Regards,
OM.


#9

Make a model of that and assign it to the footprint in question. (Either show a short cable as a cylinder on top of the board or a box representing the space needed for that.)


#10

OK.
Even if showing at least the PADs would have been easier :wink:


#11

because in a mechanical environment everything MUST be at scale 1:1
Then you can check dimensions, collisions etc without hidden surprises

as @Rene_Poschl suggested, use a 3D model to represent your connection.
No mechanical CAD would care about tracks, unless you are going to make a FEM simulation, but this is a completely different user case.

see above… you need to represent what you want to connect to your system as a 3D model

BTW, have a look at StepUp… this may help you in mechanical collaboration :wink:


#12

OK. I guess the 3D lib included in the installation files is not up to date. I’ll let you as soon as the GitHub access will finally end…

I still do not understand why would StepUp (way too complicated) do the pad stuff and not KiCAD natively on request (checkbox option).
Anyway, looks like every one wants to stay on his position. So consider this topic as closed.


#13

neither StepUp nor Kicad will give you the pads…
BTW

StepUp (way too complicated)

Why? You just need to configure your 3D prefix path and then you will be able to open directly a kicad pcb in FC, with all your 3D models (no need to make a db or whatever) … and some more tools inside… :smiley:
Anyway I’m considering this closed too.


#14

What operating system? How did you install kicad?

I tested the v5 installation on two linux distros and both have the correct 3d models. The last time the model you have problems with was scaled wrong is a few years ago. Sometime before @maui merged his models into the official library.

Are you sure you use a footprint that uses the 3d models that come with the v5 installation?


#15

As stated before, I did a clean install on both OSX and Windows. Both seem to have the same issue.
I used the DMG file for OSX and the EXE file for Windows provided by the KiCad web site download page.
The Windows version just finished pulling all 3D from Github. No changes.
I wait for the OSX version to finish pulling the 3D models.
I think I found it = I mixed up
${KISYS3DMOD}/Capacitor_SMD.3dshapes/C_01005_0402Metric.step
and
${KISYS3DMOD}/Capacitor_SMD.3dshapes/C_0402_1005Metric.step
Hence the size issue. Now I wished I had a way to globally exchange capacitors 3D models on the board :wink:


#16

Any text editor with search replace feature should do the trick.