KiCad V4.0.7 Crash on Debian Testing. Wayland?


#1

For the last 4 years I’ve been running Mint 17.3 and KiCad worked fine.
A few weeks ago I switched to Debian Testing / Buster and after that I can not run PCBnew anymore. EEschem seems unaffected. Often PCBnew crashes immediately after startup, sometimes only after [F9], [F11], [F12] A few times. ( [F12] seems to crash more often then the other canvases).

When PCBnew crashes, it often takes the whole desktop with it, to a point that no text in any program or the main menu is readable anymore. It also crashed a few times so far, that the keyboard does not react anymore to [NumLock], and I have to resort to holding the powerbutton for 5s for a hard power down.
It seems to be related to the “Wayland Bug”:


https://bugs.launchpad.net/kicad/+bug/1725920

I’m not sure whether to report this to launchpad, or to a Debian bug list somewhere, because it effects the whole GUI and system stability.
A screenshot from after one of the crashes:

I also tried “Default Xsession” before logging in, as I thought this might turn of Wayland, but this does not prevent PCBnew from crashing.
IMG_6959_small

The PC is an old dualcore E6550 from 2008, which I upgraded with a SSD and new video card a few years ago.
$ lspci
04:00.0 VGA compatible controller: NVIDIA Corporation GT218 [GeForce 210] (rev a2)
uname -a
Linux dualcore 4.15.0-2-amd64 #1 SMP Debian 4.15.11-1 (2018-03-20) x86_64 GNU/Linux

Application: kicad
Version: 4.0.7+dfsg1-1 release build
wxWidgets: Version 3.0.3 (debug,wchar_t,compiler with C++ ABI 1011,GCC 7.2.0,wx containers,compatible with 2.8)
Platform: Linux 4.15.0-2-amd64 x86_64, 64 bit, Little endian, wxGTK
Boost version: 1.62.0
Curl version: libcurl/7.58.0 OpenSSL/1.0.2o zlib/1.2.8 libidn2/2.0.4 libpsl/0.20.1 (+libidn2/2.0.4) libssh2/1.8.0 nghttp2/1.31.0 librtmp/2.3
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=OFF
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_WXPYTHON=ON
USE_FP_LIB_TABLE=HARD_CODED_ON
BUILD_GITHUB_PLUGIN=ON


#2

Is this related to the Arch Linux wxPython-Gtk3 problems?


#3

Curious - have you logged out (not using the option you used above) and chosen a non-wayland option?
If not, give it a try - I know that when I ran with Wayland, that has issues of its own such as not running Synaptic etc.


#4

My Linux-Fu is pretty limited. Until a few days ago I had never even heared of “Wayland”.
The (2nd) screen photograph is the option I tried after a crash and a hard power cycle.
I thought that the “default Xsession” was the non-wayland option.
So, if it isn’t, what is the “non wayland” option? The “Software Rendering” smells too slow to be usefull and seems to be a last resort to “get it working”.

My main goal here is not to get “KiCad Working”, but to give as much feedback as I can to developers.
The PC I use now is 10 years old and I’m probably going to buy a brand new one in a few weeks.
Getting software to crash reliably can be a help to developers to expose bugs.

I also have a multi monitor setup here. I don’t know how this is related. I tried to run KiCad with only one monitor on, and I got the error messages below.

Edit / Addition:
Problem seemed to dissapear after installing “contrib” and “non-free” and switching to the NVidia proprieatary drivers. Unfortunately another problem popped up a day later…
(Edit is for reference, I hope it does not pop this thread back to the frontpage).


#5

Yes - the Default Xsession (sorry, the verbiage escaped me at the time).
I don’t know what the diff is from the way you changed in the screen shot to actually logging out and then in with the default xsession. I do know that if you are in Wayland, some items tend not to work (as mentioned, synaptic for starters).

Cheers
Chris


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.