KiCad use with high DPI screens


#1

Having installed KiCad on my laptop my first impression is that it doesn’t play nicely with Windows 10 screen scaling.
On my laptop I have two screens, the laptop screen is 3200 x 1800 and the secondary screen is 3840 x 2160. Both screens are set to a 250% scale factor.
When running KiCad many of the UI elements are shown with inappropriate scale factors, text too big for the allocated space having parts cropped, icons miniscule and various other problems.
Has anyone else noticed such problems ?
Has anyone found a solution to these problems ?
If I reset the scale factors to 100% then all these problems go away but the UI now needs a magnifying glass to read. :frowning:


#2

There have been a number of threads about this already; did you search for terms like ‘HiDPI’ or “high DPI” before posting?


#3

Yes and it came up with one thread which had already been closed. But it was interesting to read although it didn’t give any useful advice.


#4

You don’t mention which version you are using. I think that HDPI support was added in the march to v5, but I don’t recall when it was finalized. The screenshot below is from version 5.1.4-1 running on Win10 Enterprise (v1809). (As of this writing, this is the latest stable version of KiCad available for Windows 64bit from the download website.)

There is a section of the preferences that should hopefully help. It is in the Common section of the preferences tree, so it should be accessible from any of the KiCad processes. Play around with the settings if the automatic doesn’t work for you:


#5

Thanks for pointing this out, I am using the version of KiCad which I downloaded this afternoon, I think it is 5.1.4.
I am still exploring all the menus and options. This takes a bit of getting used to after many years of using Protel.
Initial results look promising, I will get back to this tomorrow.


#6

The issues with high DPI displays are also documented on the known issues page of the KiCad website: http://kicad-pcb.org/help/known-system-related-issues/#_high_dpi_screens. This also includes the work around for an issue if there is one.


#7

Thanks, I just changed the size and colour of the grid dots which helped a lot.
I increased the size of the icons to 250% which is what the screen is configured to in windows.
The problems with the dialog boxes is that many of them open too small but so far I haven’t found any of the ones which had problems which were not re-sizable, once re-sized they seem to stay at that size for the rest of the session.
Some of the text in some places in the UI is a little cramped but these are very minor cosmetic issues.