Kicad StepUp can't push model move back to pcb(SOLVED)

Hello,

Hope this is the right place to ask this question? I can’t get the “Push 3D moved models to PCB” function to work. I get the following error message…

select only 3D model(s) moved to be updated/pushed to kicad board!
a Time Stamp is required!

I have selected the model to export, so I guess it’s something to do with the Time Stamp? But I don’t know what that is or where to look for it. Can anyone please advise?

Thanks!

as you see from the messages I assume you would like to export a model from FC to STEP and wrl… then KSU is right in replying you cannot update/push a model which is not part of an imported pcb.
I would suggest you to have a look at the ksu cheat sheet and at the videos linked in that document.

1 Like

Hi maui,

No, actually I really am trying to push a model move back to the pcb. I guess I used the wrong word “export” before. I’ve read the cheat sheet and watched the videos, specifically I am at step 5 in this “ECAD MCAD Synchronisation” video - https://youtu.be/6R6UEUScjgA?t=196.

I’ve successfully imported a pcb (just a test with two through hole resistors using the stock library footprints & models). I move one of them, then select “Push 3D moved model to PCB” button as in the video above but instead of the dialog asking for kicad pcb file, I get an error dialog with the message in my original post. It also appears in the Report view at the bottom of the FC window.

I can push/pull a pcb edge cuts from sketches fine, so I’m a bit stumped at the mo.

Thanks!

Ok, so are you on kicad 5.99? if so it could be an issue because they changed the time stamp mode…
ATM I mostly support k stable and not the dev release (I work only on stable on my side).
If this is the reason of your problem, could you please open an issue at my github repo?
I will see if I can adapt the code to support both releases.

Ah, yes i’m on 5.99. I’ll create an issue for it now, thanks!

Issue submitted…

it should be now compatible with k v5.99 … would you please update the ksu wb and test it?

hi maui, just tested it and can confirm it’s working as expected. many thanks!

1 Like

great, please mark the title as solved :smiley: