Kicad Plugin and content manager keep closing kicad

I’ve installed an external plugin which I didn’t know it supports kicad 7.0 yet.
after installing it, when I try to open plugin & content manager the whole program close.
I tried to uninstall kicad and delete all the files in Roaming folder and in documents folder and then reinstall kicad but it doesn’t solve anything.
Application: KiCad PCB Editor x64 on x64

Version: (7.0.0), release build

wxWidgets 3.2.1
FreeType 2.12.1
HarfBuzz 5.0.1
FontConfig 2.14.1
libcurl/7.83.1-DEV Schannel zlib/1.2.13

Platform: Windows 11 (build 22621), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: Feb 12 2023 01:35:19
wxWidgets: 3.2.1 (wchar_t,wx containers)
Boost: 1.80.0
OCC: 7.6.2
Curl: 7.83.1-DEV
ngspice: 39
Compiler: Visual C++ 1934 without C++ ABI

Build settings:

I’ve installed an external plugin which I didn’t know it supports kicad 7.0 yet.

There are problems if your wxPython library is compiled against wxWidgets 3.05 what is the default even for recently Ubuntu systems. Kicad V7 is now using version 3.2.1. This case, all plugins written in Python are not available.

If you expect more detailed answers, you should probably publish any info on what system and plugin you experienced this problem.

the plugin is jlcpcb tools: GitHub - Bouni/kicad-jlcpcb-tools: Plugin to generate BOM + CPL files for JLCPCB, assigning LCSC part numbers directly from the plugin, query the JLCPCB parts database, lookup datasheets and much more.
I’m running on windows 11 22621.819

Wait for plugin updates for v7 on the side of plugin developers, unfortunately this is not done by the developers of kicad

1 Like

I’ve uninstalled all the plugins from my kicad plugins folder and I still can’t open the plugins and & content manager to install any plugins.

Please supply your information as mentioned by @janvi and take note of @m852 's comments.
Open Kicad, go to help, go to About Kicad, top right hand corner: copy version info, then paste into a forum post.

Note: most plugins will not work in 7 until the authors have updated those plugins. Kicad 7 has only been available for less than a week. It will take time for the plugins to be updated.

1 Like

added the version info in the original post, and I uninstalled all the plugins and still got the issue

When you say whole program close it sounds like a crash. That shouldn’t happen regardless of what you install and is a bug.

You mean that even after completely clean install you still can’t open plugin manager?

Which exact paths did you delete?

Also I just tried Bouni’s plugin on 7.0, it seems to at least launch and download the parts db, have not tested all functions.



There is also
Don’t delete it, zip it up and upload here for me to debug but I’m sure once you remove/rename it plugin manager will work again.

It doesn’t have any of your data, it’s just cache for repositories, in case you don’t want to disclose anything.

1 Like

That actually worked, thanks so much

I think we have the sentry crash report for this btw. It appears someone at least has a bad repository cache (PLUGIN_CONTENT_MANAGER::CacheRepository) and that function dumps a stream into the json parser without try catch blocks. Someone staring at the sentry reports will probably patch that today.

There’s a few other places try{} catch{} blocks are missing


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.