KiCad pcbNew printing black pages

I am using KiCad 6.0.6, usually I take a print to check the foot prints and the PCB size before moving on to production. I noticed that with 6.0.6 the print function is generating a blank page in Black & White mode. If I change to color I am able to get the prints but again the background was dark. As an interim I fixed with applying user theme.

Print preview in default settings. Its a Black screen.

Unfortunately I couldn’t attach more screenshots with default theme in Color mode. The background is still dark which was not the case in 5.x version.

1 Like

On my Linux Box it appears to work normally with (probably) default settings.
Here output from: PCB Editor / File / Pint / Print / Preview

However, after twiddling about, I managed to get:


What I did was (In the Print dialog):

  1. Set the Output Mode to “Color” in A).
  2. Set the Print background color checkbox in B).
  3. Set Output mode in A). to B&W again.

When you set the Output mode to B&W, the Print background color setting gets grayed out, but apparently the setting of the checkbox itself does not get disabled.

This appears to be be a bug, and seems worth reporting on gitlab.
Can some people here give a confirmation (also for V6.99)

Application: KiCad PCB Editor

Version: 6.0.6-3a73a75311~116~ubuntu20.04.1, release build

	wxWidgets 3.0.4
	libcurl/7.68.0 OpenSSL/1.1.1f zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh/0.9.3/openssl/zlib nghttp2/1.40.0 librtmp/2.3

Platform: Linux 5.15.0-33-generic x86_64, 64 bit, Little endian, wxGTK, xfce, x11

Build Info:
	Date: Jun 20 2022 15:49:56
	wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
	Boost: 1.71.0
	OCC: 7.5.2
	Curl: 7.83.1
	ngspice: 36
	Compiler: GCC 9.4.0 with C++ ABI 1013

Build settings:

1 Like


Unfortunately I run the same Mint, but will confirm the same problem in 6.0.6 AND 6.99 when following your instructions.

With “Print Background Color” unchecked, I also get a proper image, as per first screen grab, for both 6.0.6 & 6.99.

This appears to be be a bug, and seems worth reporting on gitlab. Can some people here give a confirmation (also for V6.99)

confirmed and reported as #11625: print board: checkbox "Print background color" in Black&White-mode (#11625) · Issues · KiCad / KiCad Source Code / kicad · GitLab

1 Like

Thanks for looking it up. I added a remark on gitlab that KiCad V6.0.6 is also affected by this.

1 Like

Confirmed on Windows 11 as well

Application: KiCad PCB Editor (64-bit)

Version: (6.99.0-2246-gab9c42d427), release build

	wxWidgets 3.1.7
	FreeType 2.11.1
	HarfBuzz 4.2.0
	FontConfig 2.14.0
	libcurl/7.83.1-DEV Schannel zlib/1.2.12

Platform: Windows 11 (build 22000), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
	Date: Jun 28 2022 07:19:28
	wxWidgets: 3.1.7 (wchar_t,wx containers)
	Boost: 1.79.0
	OCC: 7.6.0
	Curl: 7.83.1-DEV
	ngspice: 37
	Compiler: Visual C++ 1929 without C++ ABI

Build settings:
1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.