Kicad paths/files


#1

The packaging of files, READMEs and search paths in this application are a confusing mess !

Where do footprints live ?

I have “kicad-footprints-4.0.7”, where do I copy it ? I can see paths in kicad preferences, but nothing marked footprints ?

Thanks,


#2

Kicad version 4 by default does not store the official footprints locally. It does download libraries on demand directly from github (via the so called github plugin)

If you want local libs you can store them wherever you want. Just tell kicad via the library wizard where they are.

More details see: How can i install a specific version of the footprint library?


#3

Err ok. Any documentation or examples ?

I’ve entered a schematic, generated a netlist and then tried “Assign component footprint” - I get “No PCB footprint libraries are listed in the current footprint library table.”

How do I make more progress from here ?


#4

Did you read the faq entry i linked? Because i thought i explained everything you need to add libs to your kicad installation. Maybe report what you already tried and where you are stuck.


#5

I read what you sent me, but it is assumed I understand it, clearly I don’t !


“Luckily there are snapshot archives downloadable from” … gets me lot of versions of footprints that I still don’t know where to copy them ? or how to use them ?
I have “some files” - but where do “some files” live in order to make features work ?

I’ve built from source.

http://docs.kicad-pcb.org/doxygen/md_Documentation_development_compiling.html
This says "GitHub Plugin

The BUILD_GITHUB_PLUGIN option is used to control if the GitHub plug in is built. This option is enabled by default."

Clearly I don’t know what I am doing, but best I can tell either the github plugin is not installed or is not being used as default.

Hence “How do I make progress from this point?”

IE, I need to know where to put 105 directories so that kicad can see them or how to enable the github plugin for footprints ?

/home/jon/Downloads/kicad-footprints-4.0.7
jon-HP-Compaq-Elite-8300-SFF kicad-footprints-4.0.7 # ls -l | wc -l
105

Thanks,
Jon


#6

Did you notice this is a link that gets you to a longer post?
There is a section called: “Add libs to the fp-lib-table using the library wizard.”
It should explain everything you need to know. There is no special place where you need to put your libs. Put them anywhere where you have write access.


#7

Ok, I made some progress. I re-installed kicad and made sure I had the github module installed.

Made /usr/local/share/kicad/modules and made that owner nobody mode777, got the footprints synced.

jon-HP-Compaq-Elite-8300-SFF modules # pwd
/usr/local/share/kicad/modules
jon-HP-Compaq-Elite-8300-SFF modules # ls -l | wc -l
111

I’ve somehow managed to get the schematic symbol for the kingbright 5x7 LED module TC07-111XWA in the schematic, but I cant get find the footprint.
I found stuff here, this looks useful - cant it be part of the github component library ?

*infact It should be TC07-11SEKWA, but that was the closest I could find.

I cant seem to find many 16 pin outlines, the 74HC595 I am using is SOIC16 I think.

kicad_test.tar.gz (13.4 KB)

Attached picture of the all through hole prototype.


#8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.