"Install on Ubuntu" has finally been "downdated"

The install page on telling people to install kicad-library for 6.0 has finally been sanitized.
Not very helpfully, though.
I suggest the following additions:

8: NOTE: this will only install the program, you’ll normally also need the libraries. In the Program Manager search for ‘kicad-symbols’ and install those as well.

9 If you want the help/documentation files, search for (and install) ‘kicad-doc-zz’ where zz is de, en, es, it…

In the Shell install section, add:

sudo install kicad-symbols

I think the install-recommends brings in the libraries.

sudo apt install --install-recommends kicad

Don’t know what happens in the GUI (I’m not an Ubuntu user), presumably it will install the libraries unless one vetos it.

Unfortunately, it doesn’t. I tried several times (both shell and GUI). And the previous Ubuntu install page says the same (which is one of the few correct statements on that page):

Report the output of this command:

sudo apt-cache depends kicad | grep Recommends

Here they are:
macro@macro-pc:~$ sudo apt-cache depends kicad | grep Recommends
[sudo] password for macro:
Recommends: kicad-libraries
Recommends: kicad-doc-en
Recommends: kicad-demos

I believe kicad-libraries is a virtual package so you can investigate down the chain:

sudo apt-cache depends kicad-libraries

Presumably this will depend on the real library packages.

Dunno what happened on your computer.

Well, here’s the output from your suggestion:
> macro@macro-pc:~$ sudo apt-cache depends kicad-libraries

[sudo] password for macro: 
  Conflicts: kicad-common
  Conflicts: <kicad-library>
  Conflicts: <kicad-library-all>
  Recommends: kicad
  Recommends: kicad-symbols
  Recommends: kicad-templates
  Recommends: kicad-footprints
  Recommends: kicad-packages3d
  Replaces: <kicad-library>
  Replaces: <kicad-library-all>

What happened? I followed the install instructions, that’s all. They turned out to be total manure. And now I’m sitting with the stuff.
I’m aware that W10/11 is more important, but still…

I appreciate your help and effort very much.

Perhaps check if you have a dark cloud over you like Joe Btfsplk. :frowning:

1 Like

Thank You.
I see that I’m on my own here and that problem solving (and correct documentation) is unwanted.

I think to be able to diagnose packaging problems one needs to get familiar with the tools, in this case the apt family of commands. Otherwise it’s just flying blind like an EE without a multimeter and scope.

It’s not clear to me that you failed to install the libraries. I think you did in fact get the library packages but you took a wrong turn on the first run and the error condition stuck until your personal configuration was reset.

As far as I can tell the instructions are correct and should work. My objection to the previous version was that they were poorly expressed.

Sorry, no.
Let me rephrase that:
“In order to install a software package, you normally don’t need to do much. Just follow the install instructions.”

This is unfortunately not possible with 6.0 on Ubuntu. The repository package does not work as promised, and the installation instructions are wrong. On top of that, the installation is incomplete.

I see no reason for a normal user to get into the depths of “apt” or other UNIX commands.

I’m not suggesting that normal users use those packaging commands, but when you encounter problems, you really need to show us what the state of your system is, instead of speculating what is happening, and repeating the same actions over and over in the hope that the outcome will be different.

Part of the problem is that “arrgh, I have no symbols” can be another issue to do with the choice taken on the first run. Quite a few people have encountered this and have fixed it following instructions. No symbols != no libraries. Hopefully now that the library formats have had their big upheaval, this won’t be an issue going from 6 to 7.

Anyway this is water under the bridge. I don’t believe you have established that the instructions are wrong. The dependency chain is correct, as you can see for yourself. Instructions confusing before, perhaps.

1 Like

I did.
But never mind, I’ve now installed the symbols, footprints, documentation etc. manually.
The hope that “kicad-libraries” as meta- package could solve the general problem with the Ubuntu install did not materialise, sorry. (Did anyone even test it?)
It works for me now. I don’t envy other Ubuntu users trying to update.

The package dependency mechanisms are well established and tested by years of experience starting from its origins in Debian. You are just speculating again without understanding the picture.

Try again…

I use Linux Mint which uses the Ubuntu installation.

I spent some time yesterday messing around with Kicad.
I deliberately killed off the libraries then uninstalled Kicad and then reinstalled Kicad.
As expected, there were no Kicad Libraries because I had deliberately not deleted the Config files (I was trying to emulate a new user).
I then tried to remove the Config files using: rm -fr ~/.config/kicad/6.0 , however it did not work UNTIL I did a complete computer restart (which is understandable but easily forgotten).

So, for a brand new install, copy these three lines into the terminal:


Then, when the first file is opened, up pops:

If a wrong choice is made when configuring the libraries resulting in no libraries, close Kicad, remove the configuration using " rm -fr ~/.config/kicad/6.0 ", restart computer, open Kicad and use the recommended selection.


Interesting, and tallies with my latest results which brought the installation to work on my machine.
The root-cause was the Ubuntu install page telling you to install ‘kicad-library’.
That’s been fixed now.
Thank You.

So, the old legacy Nightly PPA will non long be active.

For 5.1, I thought that had disappeared since middle of 2021? And never existed for 6.0?

Active and running, I think just unmaintained. Such installation mine updated today.

Time to change the configurations here!