Kicad on ubuntu 20.04

Doesn’t work to well.

type “export UBUNTU_MENUPROXY=0” into a console window and then run kicad from that wndow

1 Like

Please file a report on the GitLab issue tracker

What is the window manager/desktop that you are using?

What problem are you seeing? I upgraded to 20.04 yesterday, and at least with master builds I don’t see any issues with KiCad.

It runs but there is no menu. I tried three different flavors with no luck.

Googled the fix and it worked

By “three different flavors” do you mean Ubuntu flavors or something else? What KiCad version?

I get a menu just like I expect, didn’t have to set that environment variable:

I had a similar issue on Ubuntu 16 LTS / Unity.

I do not have Ubuntu 20 / Unity, but the code to automatically set UBUNTU_MENUPROXY = 0
is in single_top.cpp, in struct APP_SINGLE_TOP : public wxApp
Perhaps it needs a small change for Ubuntu 20.

1 Like

Ubuntu offers different “flavors”. I tried Ubuntu Mate,Kunbuntu an Xunbuntu with all the same results.
I am running Kicad 5.5.5+dfsg1-2Build2

This bug affects other apps as well.

I assume you mean 5.1.5?

I am on Ubuntu (plain) so not one of the 3 flavors you tried.

As JP mentioned earlier, we are setting the UBUNTU_MENUPROXY variable inside the KiCad startup, but it is only being done if the Unity desktop is detected. It is entirely possible that we may need to unconditionalize it so it is set for any desktop (that is how Audacity does it on Fedora, and I haven’t seen any complaints from it).

1 Like

I’m trying to get kicad 5.15 running on ubuntustudio 20.04
made full installation on command line as suggested here https://kicad-pcb.org/download/ubuntu/ running the program first time I should select global symbol library table but the recommended option is greyed out …
Kuvakaappaus_2020-05-01_11-44-52

Did you install the library packages, too?

2 Likes

Full installation should install the library packages also. I do not see them in /usr/share/kicad though. ```
sudo apt install --install-recommends kicad

Something went wrong with the first installation although it did not report any errors.
I removed kicad with softwarecenter tried to change sources to earlier version( 5.0 and updated apt) and installed back with the suggested commands … it seems better now but I still got 5.15

Well, of course you get the more recent version from the Ubuntu 20.04 repositories. And why do you want to install a version 5.0.x? Make to me not really sense.

Rationale:
Ubuntu 20.04 is based (at least for KiCad) on Debian testing while the preparations for the new LTS release. At some time Ubuntu did freeze their repo for the 20.04 release and KiCad 5.1.5+dfsg1-2 was pulled from Debian then. Ubuntu did some small required rebuilds of this version, this resulted in version 5.1.5+dfsg1-2build2 for the final release of 20.04 LTS.

https://launchpad.net/ubuntu/+source/kicad/5.1.5+dfsg1-2build2
This version is of course greater than any version provided by the PPA for 5.0.

$ dpkg --compare-versions 5.0.2-stable-201811280959+bee76a0~70~ubuntu18.04.1 lt 5.1.5+dfsg1-2build2 && echo "yes, second version is greater!"
yes, second version is greater!

Seems to me that the Download instructions for Ubuntu should get updated rather quickly, otherwise we will see more of such “issues”. PPAs can be tricky if you not really know what you are doing.

As it happened so that I installed 5.15 twice three days ago and get non functioning program the most obvious thing is to try another version which has been OK with my previous Ubuntustudio 18.04.
Luckily the third installation went good and I got 5.15 running good.

As you don’t have posted any log from your installations all talking now is nothing more than wild guessing. Speculating about what could have caused any potential problems is useless and a waste of time.

Thank U tijuca for support … thx all developers for nice program it is up and running and 3D models work OK.
Cheers … uffek

Please explain what you did to solve this, it will help other with the same error

Hi davidsrsb
I followed istructions on https://kicad-pcb.org/download/ubuntu/
and did not choose the first 5.1.5 Stable Release ppa but 5.0.2 instead.
I made installation on command line as instructed on greyed area.
Little lower on the same page are instructions how to get rid of 5.15 … but I didn’t notice it until I had done the “new” installation so I have few notices about missing libraries when opening schema … I’m not sure if it is related … I’ve propably made some mess trying to install many times and following help from multiple sources.
I hope U get it running … cheers … uffek