KiCad Nightly schematic editor broken

Well now the nightly is broken.
If a lock file for the schematic in the project exists upon starting the schematic editor - which might be the case if KiCad has previously crashed - the schematic editor opens up without menus, the popup dialog is shown like in the screenshot below, but there is no reaction if you klick any of the buttons.
If you klick the “X” to close the dialog window, the heading of the window will change to “not responding”, and the window manager will, after a few seconds, give you an option to close the application or wait longer.

If you need to get around it, you can rename the .kicad_sch.lck file, provided that there is not another instance of KiCad already running with the same project opened.

Let’s see what happens in a day or two… (But in case someone wants to test it, you can let us know if you see the same issue, especially if you run a different platform / OS.)


Application: KiCad x86_64 on x86_64

Version: 7.99.0-1.20230627git216541c.fc37, release build

wxWidgets 3.2.1
FreeType 2.12.1
HarfBuzz 5.2.0
FontConfig 2.14.1
libcurl/7.85.0 OpenSSL/3.0.9 zlib/1.2.12 brotli/1.0.9 libidn2/2.3.4 libpsl/0.21.1 (+libidn2/2.3.3) libssh/0.10.5/openssl/zlib nghttp2/1.51.0

Platform: Fedora release 37 (Thirty Seven), 64 bit, Little endian, wxGTK, KDE, wayland

Build Info:
Date: Jun 27 2023 17:24:46
wxWidgets: 3.2.1 (wchar_t,wx containers) GTK+ 3.24
Boost: 1.78.0
OCC: 7.6.3
Curl: 7.85.0
ngspice: 40
Compiler: GCC 12.3.1 with C++ ABI 1017

Build settings:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.