KiCAD nightly SCH&PCB workspace window size is incorrect

Schematic editor just like this.

OS info:

System:    Kernel: 5.11.12-051112-generic x86_64 bits: 64 compiler: N/A Desktop: Cinnamon 4.8.6 
           wm: muffin dm: LightDM Distro: Linux Mint 20.1 Ulyssa base: Ubuntu 20.04 focal 

KiCAD nightly version:

Application: KiCad Schematic Editor

Version: 5.99.0-unknown-ce3a84f579~127~ubuntu20.04.1, release build

Libraries:
	wxWidgets 3.0.4
	libcurl/7.68.0 OpenSSL/1.1.1f zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh/0.9.3/openssl/zlib nghttp2/1.40.0 librtmp/2.3

Platform: Linux 5.11.12-051112-generic x86_64, 64 bit, Little endian, wxGTK, cinnamon, x11

Build Info:
	Date: Apr 20 2021 08:35:46
	wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
	Boost: 1.71.0
	OCC: 7.3.0
	Curl: 7.68.0
	ngspice: 31
	Compiler: GCC 9.3.0 with C++ ABI 1013

Build settings:
	KICAD_SCRIPTING=ON
	KICAD_SCRIPTING_MODULES=ON
	KICAD_SCRIPTING_PYTHON3=ON
	KICAD_SCRIPTING_WXPYTHON=ON
	KICAD_SCRIPTING_WXPYTHON_PHOENIX=ON
	KICAD_SCRIPTING_ACTION_MENU=ON
	KICAD_USE_OCC=ON
	KICAD_SPICE=ON

In preferences -> Common, set “Canvas Scale” to something different (try 2.0)

2 Likes

Thanks for help me, It’s works! :grinning: