Kicad nightlies: Can't see step models of footprints in 3D views anymore


I’m using the latest KiCad nightly build for some commercial boards. Recently, my 3D models which I added to my footprints won’t show up anymore in any 3D view.

Is this an intentional behavior and if not, is there a possibility of displaying .stp models again?

Thanks a lot,

Could you post your version details?

I’m on Fedora 27 and am getting these builds:

Right now I am using r11806.63e55e9, but I am experiencing that issue for probably a week or so now.

About KiCad Version String:

Application: kicad
Version: no-vcs-found, debug build
wxWidgets 3.0.2
libcurl/7.55.1 OpenSSL/1.1.0g zlib/1.2.11 libidn2/2.0.4 libpsl/0.18.0 (+libidn2/2.0.3) libssh2/1.8.0 nghttp2/1.25.0
Platform: Linux 4.14.13-300.fc27.x86_64 x86_64, 64 bit, Little endian, wxGTK
Build Info:
wxWidgets: 3.0.2 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
Boost: 1.64.0
Curl: 7.55.1
Compiler: GCC 7.2.1 with C++ ABI 1011

Build settings:

Does it display 3D WRL files?
Can you browse / add STEP(.stp) files? Does it show as an option in the supported file types?
If not, It maybe something related with STEP plugin and how your package is (if it is) handling it.
But I have no suggestions how to fix it :confused:

Another thing to look at are the environment variables. KISYS3DMOD in particular. (I think there was a change regarding the use of the last “/”)

WRL are shown without problem, but thanks for the file type info: STP does indeed not show up anymore.
With an older nightly build the file type .stp shows up, however.

Any advice on how to proceed now?

Test both .stp and .STP
Sometimes coding errors get case sensitive

It may be a packager issue. Please check also with the packager person.

Nice job with the nightly build! So much better so far, but I just got started. Already I’m liking it, as I can highlight the net in the schematic.

I’m pretty sure OCE support needs to be turned on for step loading. It should be enabled according to the build page. Definitely an issue for the packager.

STEP/IGES support for the 3D viewer

The KICAD_USE_OCE is used for the 3D viewer plugin to support STEP and IGES 3D models. Build tools and plugins related to OpenCascade Community Edition (OCE) are enabled with this option. When enabled it requires OCE to be available, and the location of the installed OCE library to be passed via the OCE_DIR flag. This option is enabled by default.

It might be a good idea to report this problem over at the bugtracker.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.