Kicad negative plot pdf file export scaling issue

Hi all,

I have been using Kicad for about a month for my project. While finishing up the 2 layer design, I wanted to print out a negative plot on a butter paper.

I tried the plot/pdf option and print option from the file menue.
In the plot-pdf option, the output PDFs were on different scales so the printout was not accurate as all footprints changed because of no scaling.
In the print option, there is no negative plot option, so I used two softwares to try and invert the content inside the edge-cut. I used gimp and inkscape. In both the softwares, I faced the scaling issues as well, while exporting the inverted layers.

The not so good final way I resorted to, was to scale the printout at the Ctrl+P stage, by taking the print of wrongly scaled top and bottom from plot/pdf option and print(+ gimp/inkscape) option, measure how much it was off by, and then decide the scale, and input it at Ctrl+P.

Is there anything that I am missing?

KiCad can’t control physical printing, only what’s put into the file. Probably your OS print settings or the printer or something does some scaling. Try those settings outside KiCad if you can find them.

I suppose you have chosen 1:1 in the print dialog?

In the unstable development version 5.99 (nightly builds) it’s possible to use a different color scheme for printing. You could try that. This would be safe if you copy the project in its final stage, open it with 5.99 and use 5.99 only for printing.

You could also try plotting to ps format and convert it to pdf with some external tool.

1 Like

Thanks for the ideas. Yes I have chosen 1:1 in the print dialog. Must be an OS print setting issue.

I will try 5.99 color schemes for printing and/or plotting to ps/ghostscript idea.

Consumer printers do not have a very high accuracy.
What sort of scaling are you looking at?
If it’s like 0.5% or thereabouts, then it’s very likely the printer itself that is not accurate.

Printer settings like “fit to page” can easily add a few percent of error because of different interpretations of margins of the printable area.

1 Like

Yes you are right. I used a more high-end printer and it had less margin for error in scaling. So yeah its not just the software setting that is messing with the scaling.

My design is simple though, 0.5% error will not affect the footprints that much. The current errors that I am currently getting is about 5-10% smaller scaling (automatically even in 1:1 scale save setting). PDF viewer, gimp, inkscape are messing up with the scaling with me about to control it.

Use the Plot tool and select The plot format to PDF instead of printing. You can invert colours / mirror the image from there too:

1 Like

Yes knew this solution from a week. This path did not work for me, it seemed simple and outright working, but the dimensions were still wrong after Ctrl+Ping the saved document.

The scaling error crept in when I print from the downloaded PDF. I guess there is some issue with the pdf softwares in the system, rather than kicad being at fault.

Why use pdf at all to plot?

You can also print directly from KiCad, or export as .DWG .SVG or another format.

1 Like

Printing directly from kicad doesn’t support inverted colours (negative) it seems. You might have better luck with SVG or DXF depending on the software you use to open these, although I used pdf plots before with success.

I think pdf plots are a bit risky as it can scale up and change the dimensions of the PCB and it will be tough to revert.

Best solution I found is to use an image software to invert the PCB area, by importing it as an .SVG (kicad has an option for .svg saving in plot menu.)

Historically plotting has been more accurate than printing.
A common cause of scale errors is getting A4/US letter paper selection wrong

1 Like