KiCad Linux Install script


#1

Has anyone else here faced problems updating KiCad using the Linux install script recently ? I know it worked earlier for me as that’s how I installed it on my machine running Ubuntu 13.10.

Two problems :

  1. The script now seems to be downloading kicad.bzr in the ~/kicad_sources/ folder, but looking for this folder in the root home folder during installation.
    The kicad-lib.bzr and kicad-doc.bzr are both nested correctly under ~/kicad_sources/

  2. The script fails at Step 6 with the following error :

common.copy /home/anool/kicad.bzr/boost_root/lib/libboost_regex.a
…updated 10898 targets…
[ 39%] No install step for ‘boost’
[ 39%] Completed ‘boost’
[ 39%] Built target boost
make: *** [all] Error 2

Any ideas ? My Linux-fu is not too strong, so any help is appreciated.

Anool


#2

There were important changes and bug fixes made to make script recently, I believe your problem may be related to this.

https://lists.launchpad.net/kicad-developers/msg14841.html


#3

Last week I did a fresh install of Ubuntu 14.10 on a formatted disk, and still had the script fail as it could not detect wxwidgets 3.0 (although a check confirmed that I had it already installed). As I needed it to be up and running as soon as I could manage, I instead tried the manual install instructions at this link:
http://www.kicad-pcb.org/display/DEV/Building+KiCad+on+Linux
and that worked fine - resulting in ver 5256 being installed.

I tried again today, and it still failed at step 6, but with a different error:

step 6) compiling source code…
CMake Error at CMakeLists.txt:403 (include):
include called with wrong number of arguments. Include only takes one
file.

– Check for installed OpenGL – found
– Found Glew: /usr/lib/x86_64-linux-gnu/libGLEW.so
– Check for installed GLEW – found
– Check for installed Cairo – found
– Bazaar version control system version found.
– Kicad Bazaar build version: (2014-11-14 BZR 5284)
– Configuring incomplete, errors occurred!
See also “/home/anool/kicad_sources/kicad.bzr/build/CMakeFiles/CMakeOutput.log”.
Makefile:792: recipe for target ‘cmake_check_build_system’ failed
make: *** [cmake_check_build_system] Error 1

I can post the contents of the CMakeOutput.log if someone wants to take a stab at figuring out the error.


#4

If you are just looking to get recent build installed on Ubuntu then you can use https://code.launchpad.net/~js-reynaud/+archive/ubuntu/ppa-kicad


#5

Here is my build scripts to build and generate debian packages from Kicad source: https://github.com/ceremcem/kicad-install

This layout is specifically designed to ensure building Kicad from a specific commit in order to make all team members run exactly the same version of Kicad, thus allowing all members exchange their projects coherently.