Kicad libs missing [how to setup local symbol/footprint libs in Windows]

Ok, that’s good… I just hope the footprints are of the .pretty kind and not legacy… as I have no up-to-date experience to make those work.

Edit the KISYSMOD path variable and point it at your module folder, the one that contains the footprints.

We go from there.

Does your install find your local symbol/part libraries - no problems?

1 Like

Nope, they’ll all legacy files as I made them on an older version.

Ok, once you got the KISYSMOD set correctly, open PCBnew… go to >Preferences>Library Manager… should see something like this:

Remove all that are not working / you don’t want to load.
Then hit [Append with Wizard] and it should drop you off in the footprint directory - if you set the KISYSMOD path correctly…
Should be a no brainer from there.


I cannot get this to work.
This was so much easier with the older versions.
Im still getting the same error, ive tried uninstalling and re-installing.
Libraries do not show up in CVpcb.

What should my KISYSMOD be set too?
Right now its set to a local folder which isnt working.
Shouldn’t it be set to the github repo??

The setup/config for footprints/3d models differs from the part/symbol library setup, because the layout part of the program already underwent a change and the schematic part didn’t yet - but it’s coming.
To set up symbol/part libs globally (for all projects) is not really taken care of in the GUI afaik, you have to do it manually - the GUI only set’s up the porject. The footprint/3D model setup is global and will be for all projects.
Thus we have different ways for doing similar things for different parts of the program at the moment.
It’s confusing, it,s not nice, but it is how it is as there are only so many programmers working on KiCAD and they only have so much time.

Also, un-/over-/reinstalling KiCAD won’t help in your case - you need to configure it.
And there are many ways that lead to Rome, I try to show you the IMHO most straight forward ones…

#Local footprints & 3d model setup looks like this:

My KISYSMOD and KISYS3DMOD path variables are being set here:

Start > Control Panel > System > Computer name, domain… ‘Change Settings’ > {new window} System Properties > {Tab} Advanced > Environment Variables > System Variables …

that’s why they appear greyed out and can’t be set in KiCAD anymore, but you don’t have to do that (just explaining why mine look like they do).

KISYSMOD: point it at your local footprint directory
KISYS3DMOD: point it at your local 3d model folder

Either set those two variables in KiCAD or in your Windows Environment Variables dialog.
Both ways work.

Once you got that it should be straight forward to add footprint ‘repos’ via the GUI

or the text editor in the fp-lib-table file here:


#Local symbol/parts setup looks like this:

As I said, the schematic tools didn’t get a refurbishment yet, so their global setup is a bit more clumsy and not as straight forward with global path variables… you have to dig deeper there and use a text editor if you want to make the global setup stick.
Otherwise you have to use the GUI method for every new project you’re starting…

The symbols/part libs and the path to them is set in the .pro file that resides in each project’s folder.
That .pro file has been assembled from a template file and other stuff that KiCAD puts in there when you create a new project.
This means, for your case (no old projects) you just have to configure the template .pro file once and all new projects will contain this setup. For older projects one would need to do this manually for each and every one of them in the project folder.

The file (the template) is located here:

C:\Program Files\KiCad\share\kicad\template

Open it with a text editor and you’ll find something like this:

update=22/05/2015 07:44:53


You’re interested in the part that comes after [eeschema]
The first entry of interest for you is LibDir.
That essentially is the “KISYSSYM” path variable for the schematic part of KiCAD.
Point it to your symbol library folder. You can have more than one defined here… just append the next one by doing this:

LibDir=c:/folderA,d:/folderB (or was it a semicolon ‘;’ as separator ?)

Ah well, KiCAD willl tell you what it wants.

Then a bit down are your local library entries.
The numbers need to increase for each entry and the entry names should be the library file names without the .lib ending (otherwise KiCAD will tell you that it doesn’t like it).

You can test this setup on the projects .pro file before you manipulate the global file.
Or you can even modify the local .pro file with the GUI in EEschema and copy the results into the global file, so it sticks and you have to do it only once (or anytime you change something with your local libs).

For the GUI way - this will affect your current project only! - open KiCAD, then EEschema and there under preferences > component libraries it should look something like this (left window in that screenshot):

Remove any paths/libs in the upper window you don’t like, that don’t work or whatever.
Then hit [Add] button #1 and add the path to your local libs. I prefer absolute, but depending on your setup relative might be better.
This will put a path into the .pro file where it says ‘LibDir’.
Once you got that, use the [Add] button #2 and add libraries… one by one (and yes, you have to navigate to them manually each time… it sucks.
That’s why I mentioned the text-editor way up there and the global setting file so you don’t have to do this for every each and one of your projects.

When you hit ok you can test the setup working right there by placing a symbol from one of the libs.
The right screenshot is demonstrating that…



The KISYSMOD is set correctly, but when I try to add in the append wizard the
‘NEXT’ button is greyed out so I cant click it, even though the correct folders are selected.

You need to select a single footprint library (legacy format) or folder (.pretty, current state of the art).

The screenshot depicts the basis folder for your footprint libs only, KiCAD doesn’t think that this qualifies :wink:

might pay to set the filter (drop down menu with ‘All supported library Formats’) to the one you want… either .pretty (=folder with .kicad_mod files) or .mod.

You can also select multiple files/folders. But if you select any folder or file that isn’t a library the button back to grayed state.

1 Like

Ah, didn’t know that. :thumbsup:

The other day I mentioned to @Andy_P that you’re pretty knowledgeable how to deal with KiCAD the GUI way :slight_smile:

Apparently I dont have any supported file types, no .mod or .pretty
Doesnt kicad come with any??
It used too.

I have only .lib and .equ and .wrl files.
Nothing else.

Didn’t you say you had your personal libs and modules up there?
I thought we are on a mission to get those linked into KiCAD… if you don’t have any then you either need to load those footprint repos from somewhere (note 1) or ask @keruseykaryu how to set up the github stuff… I don’t know how to do that as I don’t need it.

note 1)
download all .pretty folders from the official github repo and run them locally is an option here… but you can also (@keruseykaryu knows how to) set up kicad to do that for you… really your choice.

I tried the wizard for the github repos, kicad says they are all invalid

Ok, I can only show you the download manually way - I have no clue how to solve the github thing.

Browse here:

There is a link for the footprint repos… download, unpack, and then do as I told you up there for a local install.

If you want to download single footprint repos follow the github link on that website, go back one branch in the KiCAD tree there and you will land here:

Chose any of the .pretty repos and download those. Should be the same content as in the tar.gz up there.

essentially the github path there ^^ should be the KIGITHUB path variable.
Problem probably are the repo names.
For solving the github problem you need to make sure that the names of the repos on github are the same as the names that you have got in the footprint repo manager list.
Your global repo list looks empty, so you would need to get a new fp-lib-table file that has those names set correctly.

This is a very very old one and it’s absolutely outdated, but should give you an idea how it is set up (I truncated it to be smaller):

This might happend. Make sure you have correct URL to the GitHub repo in Wizard.
There were a bug in one release with the protocol. ULR was http:// instead of https:// This URL is saved in KiCad user configuration in kicad_fplib_url=, and you may inherit wrong URL from one of previous (4.0 RC1, RC2) releases.

Editor=C:\\Program Files (x86)\\Notepad++\\notepad++.exe

Ok next silly question: where is the kicad user config file??

This is not a single file. These files are saved to %APPDATA%\kicad under Windows.

AHA! It was http not https.
Just added an ‘s’ in the append wizard and got my libs downloaded.
Just need to add it in the config file so its permanent.
Thanks for all the help guys.

Having more problems.
Now PCBNew is giving me "footprint not found error for all components when I try to read a netlist.
After finishing a schem and adding footprints in CVPCB and opening PCBNew I get nothing, so I go to
netlist button and click read current netlist after selecting the right one I get the error’s.

Error pix:

My libs paths:

Do you generate netlist from schematic before starting CvPcb (Wrong!) or after (Right way)?