Kicad libraries and footprints missing

Hi,
I’ve just upgraded to 5.1.12 and deleted the App data Kicad folder first.
Almost sucessful, apart from one component :16-Lead Small Outline Integrated Circuit (SOIC), JEDEC MS-012, 0.150 Narrow

I had it in previous versions, but I’m trying to be careful.

Where can I find this compnent footprint please?
Camerart

I have three footprints with the string “MS-012” in them, all SOIC, and one of them has 16 pins:

Hi P,
In the last few minutes, I managed to get the footprint. I found it in SO, then SOIC, but at first it didn’t work, so I messed about for a while changing file names, and finally got it in.
Totally un professional I know, but it’s IN.
Thanks C.

I often use the footprint editor for finding footprints because the search bar has a regular expression like syntax and can search for multiple sub strings in names and descriptions in footprints.

It works very similar to the search function in Eeschema / Place / Symbol.

Hi P,
I normally try as hard as I can to keep up with the programs, I use which get updated and change periodically, which always throws me for a day or two, but I have to make quite a lot of effort and concentration, to move forward.
I also forget procedures, expecially if they have changed, and in this case of the missing footprint, I realise in searching, that I asked the same question hear earler in the year.
As in this time, I usually muddle through, with help of course from these forums.
Thanks, C.

If I’m in the middle of a project I’ll stick with what Ive got, if it works. Updating mid-flow can be project breaking at times.

Hi M,
I would also leave well alone if I’m in the middle of a project, but this one has gone on for years and a few itterations, so I had to update along the way.
C