Kicad icons in sub-menus (rigth click) not showing in Pop_OS

Recently switched to Linux to experiment with it and been using Pop_OS because of its ease of use, as part of my workflow i use kicad for pcb/schematic design and i’ve found that no matter which source or package i use there are no icons in any sub-menu, what could it be? i’ve tried flatpak, deb and ppa, they all have the same issue, and while i can work with that its much easier and faster with icons.


  • Menu / Preferences / Preferences / Common / User Interface / [ ] Show icons in menus - option unavailable/not showing

Menu / Preferences / Preferences / Common / User Interface / [ ] Show icons in menus

I would do that if i could, that option isn’t present

I’m using Debian 12.
Help > about > copy version info
Application: KiCad x86_64 on x86_64

Version: 7.0.9+1, release build

wxWidgets 3.2.2
FreeType 2.12.1
HarfBuzz 6.0.0
FontConfig 2.14.1
libcurl/7.88.1 OpenSSL/3.0.11 zlib/1.2.13 brotli/1.0.9 zstd/1.5.4 libidn2/2.3.3 libpsl/0.21.2 (+libidn2/2.3.3) libssh2/1.10.0 nghttp2/1.52.0 librtmp/2.3 OpenLDAP/2.5.13

Platform: Debian GNU/Linux 12 (bookworm), 64 bit, Little endian, wxGTK, plasmawayland, wayland

Build Info:
Date: Nov 30 2023 19:42:07
wxWidgets: 3.2.2 (wchar_t,wx containers) GTK+ 3.24
Boost: 1.74.0
OCC: 7.6.3
Curl: 7.88.1
ngspice: 39
Compiler: GCC 12.2.0 with C++ ABI 1017

Build settings:

Application: KiCad x86_64 on x86_64
Version: 7.0.9-7.0.9~ubuntu22.04.1, release build
wxWidgets 3.2.1
FreeType 2.11.1
HarfBuzz 6.0.0
FontConfig 2.13.1
libcurl/7.81.0 OpenSSL/3.0.2 zlib/1.2.11 brotli/1.0.9 zstd/1.4.8 libidn2/2.3.2 libpsl/0.21.0 (+libidn2/2.3.2) libssh/0.9.6/openssl/zlib nghttp2/1.43.0 librtmp/2.3 OpenLDAP/2.5.16
Platform: Pop!_OS 22.04 LTS, 64 bit, Little endian, wxGTK, pop, x11
Build Info:
Date: Nov 8 2023 19:01:25
wxWidgets: 3.2.1 (wchar_t,wx containers) GTK+ 3.24
Boost: 1.74.0
OCC: 7.5.2
Curl: 7.88.1
ngspice: 38
Compiler: GCC 11.4.0 with C++ ABI 1016
Build settings:

This is mine, Pop OS

I have not tried Pop OS but I wonder if they have relocated the icon directory and whether there is some search path that needs to be specified to Pop OS desktop manager to find the standard icon directory (which is /usr/share/icons on my system, fairly typical),

I have used kicad on pop-os for a couple of years or so and never noticed there was such a thing as sub-menu icons in kicad. Like you, I don’t have them:

So I went to peek at my backup system on win, and I see what you mean:

Perhaps it’s a windows thing – yee canny hae dark mode, but yee git these daft wee icons.

And I really quite like pop-os. Added nemo for an up arrow for files. Added Otis gnome theme to refine something I can’t recall at the moment. Some tweaks and it is a clean and modern desktop (unlike so many that still look 90s-vintage). I played with mint/cinnamon for a bit, which was decent but looked too much like windows for me. fwiw.

1 Like

You will only see the checkbox for showing the icons if your current theme supports showing the icons in the menus. Desktop environments have their own control for selecting this normally, so check in your appearance settings for something that says “Show icons in menus”, or something similar (I am not sure exactly what it is called in PopOS’s environment).

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.