KiCAD github plugin problem

The actual problem seems to be that KiCAD’s github plugin is looking for
when it should be looking for
(seen by hovering over the “download ZIP” button on github)
Is there a way to control what the plugin appends to the github URL?

This seems related to <a href=">this thread, which features a screen shot of the error messages (notice the error is NOT FOUND). (I’d link it here, but “new users are not allowed to include images in posts”)

Unfortunately that thread doesn’t seem to indicate the correct solution.

My KiCAD version: 4.0.0-rc1-stable
The 4.0.1 release notes do not mention this issue, so I haven’t tried updating.

make sure you have a valid fp-lib-table, as mentioned in the other thread fp-lib-table is not updated when installing a new kicad version.
what is the output of:

$ diff <(cat .config/kicad/fp-lib-table) <(curl -s


Well, I’m stymied. The only differences were additional libraries in my table that weren’t in the one you linked. Nevertheless, I replaced my table with that one and all the errors went away. I then added my custom libraries to that table as well and still no errors–it is working fine now.

It seems as though perhaps an error retrieving one library can prevent another from loading correctly. For example, none of the error messages that appear mention the “Pin_Headers” library (and its line is identical in both tables), but it remains unloaded nonetheless.

This seems like a bug. A bad library table entry shouldn’t prevent good libraries from loading correctly.

yes that’s my understanding of how it works. one error in fp-lib-table prevents all the rest of the libraries from loading.