Kicad filled zones wont filled error

Hi there,

This is the first time I am building a complex board using Kicad, previously I’ve managed to done some simple designs.

Currently I have the error of trying to insert the filled zone for Ground, my whole board won’t be filled after hitting B short cut (T.T) I know usually it might be related towards on how I routed things, and during initial designs, there might be some missed zones, but I never expected it to be this major

Below is an example, the LED GND (D1 and D2) is not showing any external white lines, so it is connected GND. But the transistor (Q1 and Q2) has, despite it being in the same layer as the LED

I have already tried playing around with different routing and and different placements of components, yet no avail. Have anyone faced similar issues before?

KiCad Version
Application: KiCad (64-bit)

Version: (6.0.7), release build


  • wxWidgets 3.1.7*
  • libcurl/7.83.1-DEV Schannel zlib/1.2.12*

Platform: Windows 10 (build 19043), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:

  • Date: Jul 26 2022 02:49:38*
  • wxWidgets: 3.1.7 (wchar_t,wx containers)*
  • Boost: 1.79.0*
  • OCC: 7.6.0*
  • Curl: 7.83.1-DEV*
  • ngspice: 37*
  • Compiler: Visual C++ 1929 without C++ ABI*

Build settings:


So let me just add some new stuff,

For the “whole board cannot be filled” basically I “fixed” it by copy pasting it to new project.

While it does look better visually, fact remains is the GND for Q1 and Q2 still is not connected to GND

Q1 and Q2 ARE connected to ground - you can see that they are connected to the copper flood.
But, there is something else that is also supposed to be connected to ground and isn’t. What could that be? - look at the schematic.

Thanks, I see your point!

I did some checking, seems like every components that I wanted it to be connected to GND, mostly are.
With the exception of several ICs that are unable to connect GND
I believe this is the main problem, and it is related towards the footprint of the ICs itself, whereby Kicad cannot fit the route in basically. Once I am able to connect it, it should solve the whole thing.

However Ive tried to manually connect as below, by adding a GND via and connect it.

Assuming my theory of the footprint being too small for Kicad is correct, will above solution suffice (add a GND via and connect it manually)? Or is there a more “official” method?

That’s the correct way to do it.

They are connected to GND fill but you have several GND fill islands not connected to each other.
Use vias to connect top GND fill to bottom GND fill.

1 Like

Thanks very much, will do!

Yep, finally got the general gist of it, thanks!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.