Kicad/Eeschema 4.07 hangs on choose footprint


#1

Greetings!

Windows 10 decided to crash on me yesterday. Unfortunately Kicad was open, though not actually being used.

Later, after windows had restarted and finished its updates I got back to the Kicad project and found a problem that I haven’t been able to get past.

In Eeschema I right-clicked on a symbol and tried to assign a footprint. All is normal, until the library browser came up. Nothing in Kicad would respond, and task manager showed Kicad idle. I had to kill it.

I have reinstalled Kicad, and checked all the paths I can find or think of.
I have tried the same thing with a brand new project, with the same problem.

I will admit that my understanding of Kicad’s various paths and libraries is a little, er, hazy so I’d very much appreciate some suggestions on how best to proceed to get up and running again.

Thanks!
Doug


#2

Is it possible that you have kicad setup to use on demand github libs? (github plugin) And yes the default setup is to use these on demand libs.

Check it via the footprint library manager found in the preferences menu of the footprint editor or pcb_new.
If the libs are of plugin type GITHUB then you use on demand libs.

If this is the case then kicad will download a zip archive of the footprint libs every time it needs them. (The downloaded files only live for one session. So restarting kicad means you will need to download them again.)

This is one of the reasons why it has been decided not to use the github plugin in the future version 5 release. (It is not even the most important reason.)
I would suggest you setup local libs. Have a look at the FAQ for details about that: How can i install a specific version of the footprint library?


#3

I actually had previously set up Kicad to use the local libraries,
for various reasons that I’m sure are fairly well known.

The problem did seem to be related to some sort of corruption in the

footprint manager data. I deleted all my libs, shutdown kicad,
opened it up again, added the same libs back, and now things seem to
be ok.

It seems odd that kicad can apparently hang, silently, but I'm back

up and running which is the main thing. I like kicad enough to
forgive it some weirdness!

Thanks,

Doug

#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.