Kicad doesn't recognise .dcm file

Hi, Im using Kicad 5.1.9 and I’m trying to import a library and it’s associated footprints - the symbols are fine, the .dcm containing the footprints isn’t recognised under Preferences>Manage footprint libraries>Add existing library to table

I can add symbols in the schematic view, but when I come to match the footprints there are none and the library isn’t shown.

what am I doing wrong?

The .dcm file isn’t a footprint, it’s part of the symbol (it contains the datasheet and some other metadata, i.e. the DoCuMentation, but that’s not really relevant for your purposes). This is kind of a weird implementation detail that is smoothed over in the upcoming version. You shouldn’t have to worry about the .dcm file at all, kicad should take care of it automatically.

Footprint files end in .kicad_mod, and they are contained in libraries which are folders that end in .pretty. The libraries (.pretty) are what you want to add to the footprint library table.

This FAQ may be helpful: How to get a downloaded symbol, footprint or full library into KiCad version 5?

1 Like

oh, yes I beg your pardon - there is a folder with separate .kicad_mod files, but I can’t see them or any other .kicad_mod files when I go

Tools > Edit PCB Footprints
Preferences > Manage Footprint Libraries>add existing library to table

what am i missing?

A footprint library in KiCad is just a normal folder (directory). You add the folder which has .kicad_mod files inside it. You don’t add individual .kicad_mod files as libraries.

ok thankyou! that works.