KiCad crashed and restarted

OS: Windows 11
Kicad Ver :7.07

Kicad crashed and restarted when I try to edit the symbol properties, adding the net label, adding the global net label, adding the hierarchial label etc. Not able to fix it. Tried to restart the system. Changed from 3 monitor to single display also. but no issues

Do you have any PlugIns installed ?

I didn’t. May I know where can i find the plugins.

You can see if you have any PlugIns installed from the Plug In and Content Manager . . .

. . . but if you don’t then your issue is NOT related to this one :

Installed the plugins. But same issue continues

It’s the other way around. There is no need to install them. The thread linked to describes crashes of KiCad that are probably linked to installed plugins, so to get more stability you should UN-install the plugins, but if you had none, there is nothing to uninstall either.

1 Like

As Paul mentioned, you don’t need to add PlugIns . . .

Have you tried running KiCad “As Administrator” ?

Please do not advocate users to run KiCad as administrator. It will risk corrupting their file permissions by doing so.
Administrator has nothing to do with impacting crashes here.

@Arumugam_Elumalai If you opted into data collection, you can provide us with the unique id in Preferences > Data Collection to take a look

1 Like

Did you check the GitLab issue tracker, if there is already a bug descriptions that fits the bug you are experience? I searched for it and found some that maybe related, maybe not. If there is no description of your bug already, can you create a new one?

And please add more detailed versions info (From Help->About KiCad ->Copy Version Info). Also check if this happen on all (and new) projects or just a few. If it only happens in some or a single project(s), upload a project that causes the crash.

More information could also be helpful: Did you use the mouse or keyboard shortcuts? When exactly does this happen?

How can I share the data to you?.

Its opening without any issues.

Post the id string from here

1 Like


Good news is, we have crash reports and it’s related to fonts.

However figuring out why is another question

1 Like

Try the latest 7.0 testing build

You can use the install ending with -x86_64-lite.exe

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.