Kicad crash 10 times at day on W11

Hello:
I am getting a problem with kicad. The software freeze the screen with the mouse pointer making a circle for about 4 seconds. After this time close, and restar offering the possibility to restore from last saved.

The problem become worst as the schematic grow with more components and tracks. Under certain circumstances is reproduceable, but the main cause is aleatory.
I will explain better:

  1. I am editing one page of the schematic (the root in this case).
  2. I put 6 connectors IDC and press CTRL+S (i made this frequently)
  3. I copy and paste GND symbol 6 times (one for each IDC)
  4. The kicad Crashes. (no apparent reason)
  5. The schematic is good but is missing the GND´s
  6. I copy and paste GND symbol 6 times (one for each IDC)
  7. The kicad Crashes. and jump to point 5. I reproduce the fail loop 5 times.
  8. I copy and paste GND symbol 2 times (one for each IDC) and press CRTL+S
  9. I copy and paste GND symbol 2 times (one for each IDC) and press CRTL+S
  10. I copy and paste GND symbol 2 times (one for each IDC) and press CRTL+S
  11. At this point i placed the 6 GND but no crash. And the GND is in the same place of point 6.

What is your full KiCad version?
Copy the text from Help / About KiCad / Copy Version Info and then post it here.

At a minimum, you should make sure to always use the latest bug fix release (third number of KiCad version numbers).

There’s a facility to enable Sentry crash reporting and give the devs access to the data. Here’s a previous topic about this: Kicad 8.0.x crashing, and how to report? - #8 by JamesJ Good luck.

PS: Shouldn’t W11 crash 11 times a day, and W10 crash 10 times a day? Sorry, silly joke. :crazy_face:

Application: KiCad Schematic Editor x64 on x64

Version: 8.0.3, release build

Libraries:
wxWidgets 3.2.4
FreeType 2.12.1
HarfBuzz 8.3.0
FontConfig 2.14.2
libcurl/8.5.0-DEV Schannel zlib/1.3

Platform: Windows 11 (build 22631), 64-bit edition, 64 bit, Little endian, wxMSW
OpenGL: Intel, Intel(R) Iris(R) Xe Graphics, 4.6.0 - Build 31.0.101.5186

Build Info:
Date: Jun 3 2024 19:04:47
wxWidgets: 3.2.4 (wchar_t,wx containers)
Boost: 1.83.0
OCC: 7.8.1
Curl: 8.5.0-DEV
ngspice: 42
Compiler: Visual C++ 1939 without C++ ABI

Build settings:

1 Like

i see you are under windos, you could activate the crash log so that the developers can receive all the infos needed to try to understand the cause of the crash.

ps. i see now, some feline friend already suggested that :slight_smile:

It’s worth describing your exact PC model, the Intel Iris XE is a rare graphics GPU.

how i enable the crash log?
The Laptop is Dell vostro 15 3530
I use 3 monitors: Laptop, 20" HDMI, 20" Usb C

Its in preferences . . . you may need to reset your ID if there is not one in there already . . .

Excellent i activate this yesterday after write this post. Today i am out of the office tomorrow i come back

Today crashes 2 times.

  1. when i do the “reannotate schematic”
  2. I drag a wire